EN X1 not importing 2010

I have read earlier messages about getting the patch to add 2010+ year information.  What I am wondering about now is after the patch is installed on EN X1 will I have to enter 2010 on all citations already entered in the Library without a year?  Thanks,

A bit of a “fudge” but how about sorting the library view on YEAR, selecting and then “show selected” (from the references menu) all those with out a year and using the “Change and Move Fields” option (under either References or Tools depending on the version) and add 2010 to the year.  If you do have other records that don’t and shouldn’t have a year, you could deselect or hide those before the global edit. 

Thanks Leanne for this ‘fix’.