Invalid class string - end note x2 - vista - office 2003

I am getting this error message all the time when ever i try to insert citation. It was working fine previously. I did not work with endnote for a while and i started working again. First i didnot get the tool bar, then i thought it needed update so i updated it… from then i am gettting some or the other error message. when i go to end note it says member not found. Can some body help regarding this…

Hello Loga,

You may find the information at helpful.

If that doesn’t work, you may need to disable User Account Control in Vista, then repeat the listed steps.  Take a look at for more information on how to do that.

I am still getting the same message, I tried reinstalling the endnote but still having the same problem. I tried all the steps mentioned by you. But one thing I found is I have endnote x tool bar and not endnote x2 tool bar in word. Is that a problem, if so where can i find x2 tool bar. I do not know whether x2 tool bar exists but I see there is a difference in the tool bar which I already had but now after updating and reinstalling my tool bar looks different and says invalid class sting…please help. I have tons of articles saved and need to write and complete my project…asap…kindly help…thanks a lot…I appreciate your time and support