Page number digit groupings: adding comma separators

Hello, appreciate ideas on this little picayune piece from my persnickety publisher. Page numbers 1000 or greater are supposed to have comma digit groupings (, for example, 1,000).   Thus their style is: Journal Name, v. 43, no. 10, p. 3,919–3,925 not “3919-3925.”

  Didn’t options within the style defintions to change number formats, nor to change the OS setting. Must be missing something!? Thanks in advance. Cheers.

Chris (EN X7.1, Word 2010, Windows 7)

Don’t think there’s an automatic fix. A workaround might be to add commas to the page numbers in the Pages field of the corresponding record. However if you wish to maintain the original page numbers you could create a custom field, copy the Pages field contents into the custom field, manually add commas where needed, then modiy the output style to use  the custom field.