Problem with searching, sorting, & more in large X5 database

I use one EndNote databse for my work. It is always growing, and is now around 1500 references (the ENL file is about 1 MB). (Most of these hafe PDFs attached.)

All was going fine, until a few days ago:

  1. Sorting by year seems to sort in a random way (altough for a given group of records, it is the same each time).

  2. Within a group, sorting by Author, Title, and Journal work fine. However, in the “All References” view, none of these work at all. 

  3. Searching will work for certain references(maybe 1/3 of my items?), all the time, but will never work for the rest of my references.

  4. Tools->Recover Library said “0 references were recovered…” and subsequently produced no new ENL file.

I have searched online, and specifically here, for any advice. The closest that I found was this:

I checked and changed that this said, but it did not help.

This is quite frustrating, as I cannot find most references when I need them. 

I am grateful in advance for any assistance.


If the Recover Library functionality was unable to recover any records, you may want to try creating a new .enl file for your EndNote library.  You’ll find the steps for creating a new .enl file under the “Advanced Recovery Options” section within the following knowledgebase article:

Alternatively, please let me know if you’d like to send me a copy of your .enl file and the associated.Data folder, so that I could walk through the process for you.

Best Regards,
Jimmy M.
Customer Technical Support Representative Scientific
Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support

For the sake of follow-up: In general, this worked. I had some problems with long file names, so instead of doing this on the desktop, I did it in the C: root, so that the path was as short as possible. This required administrator rights. Also, the process of “repairing” the new, empty .ENL file would cause EndNote to work for about 5 minutes, and then “not responding” according to Windows. I noticed the the .ENL file was then exactly as large (in KB) as the original, so I force-stopped EndNote, and then re-opened it with the new .ENL file. It then had to rebuild using the PDF index (Or something) and that took 10 or 15 minutes. Regardless, it now appears to work. 

And thank you!

  • J

I’m glad to hear these steps have allowed you to access your EndNote library!  If you experience library corruption again and are unable to resolve the issue with the same process, definitely get in touch with our Technical Support department.

Best Regards,
Jimmy M.
Customer Technical Support Representative Scientific
Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support

Mine don’t appear corrupted but it does have 3191 references. The whole database sorts alright on Title, but can’t be sorted on anything else unless I do that within a group that has less than say… <1000 references (largest working group is 870). However, in my largest group with 2321 references, I can’t sort by any field other than Title.

What exactly is the problem here?


Greetings nman1011,

To be certain, have you tried running Recover Library to confirm the newly-recovered library doesn’t behave in this same manner?

Please let me know what you find.

It’s okay now. I didn’t recover the library but exported and imported the library using the EndNote Export and EndNote Import because I had to batch edit File Attachment links.

I’ve had the same problem and in my case it was a problem with too long file names or more precisely too long folder paths. When I moved the .enl file and the .data folder out of the sub-sub-sub-sub-sub…folder they were in and placed them directly into "C: ", the standard library recovery process worked just fine.

I dont know why the error message in Endnote is not able to tell the user about the reason for the failed recovery, it would be useful.

best of luck to everybody!