typeahead not working

I have just updated from X4 to X6 on two computers, both of them Windows 7 64-bit (one Win 7 Pro, one Win 7 Enterprise). I was figuring out what was different about EndNote and getting good and grumpy about Rating and Read/Unread.  Then I noticed that on one machine, typeahead didn’t move down the library to match a record:  instead, every keypress produced an error ping. I was about to give up on EndNote X6 as a total disaster when I realised that typeahead works as normal on my other machine.  So I tried System Restore on the problem installation as far back as it would go, and sure enough, typeahead was broken on EndNote X4 too.  It’s clearly not an EndNote problem, therefore:  it’s either a hardware problem or some WIndows setting or some other software.  But I have no idea where to start looking for a solution.  Any ideas, anyone?



Further info.  Deleting the rdb folder and allowing EndNote to rebuild it will solve the typeahead problem. This suggests that the problem may after all be located within my EndNote database.  Does that make sense?

But deleting the whole rdb folder means you’ve lost term lists and I’m not sure what else.  Is it possible to specify which particular file(s) in the rdb folder is/are responsible for allowing/blocking typeahead, so that a more targeted deletion can be tried?  Thanks.

If you run into an issue with your library, a better option is to recover it. You can follow the steps found in this article:


Thanks, Jason, but I’m not sure this is the solution.  Can I just check with you if I’ve understood correctly?  I’ve tried the following four recovery scenarios.  Remember, the existing file (4651 references) seems to work fine in every way EXCEPT that I can’t jump down the bibliography by starting to type an author name - what I call typeahead.:

(1) Simply opening the existing db by using Tools | Recover rather than Open.  Produces what seems to be a functionally identical copy of the db.  No typeahead.

(2) Recovering from the existing data folder, copied and renamed, with an empty .enl file of the same name created by Notepad++.  Also produces what seems to be a functionally identical copy of the db.  No typeahead.

(3) Recovering from the renamed existing .enl file with no matching data folder.  No references are recovered.

(4) As (3), but with an empty matching Data folder containing empty rdb and trash folders.  No refs recovered.

None of the above represent any improvement.  Is there some other Recovery permutation that I’ve missed?



Hello David,

If the “typeahead” functionality was not restored through the standard recovery method, your library was likely damaged in a unique way. If you can provide a compressed copy of the original library, I can share this with our software engineers. You can create a compressed copy of the library by following the steps found here:


OK, thanks. Where should I send the compressed db?


Hello David,

You can either use the Attachments feature in reply to this message if you want to include it in the Forum or you can certainly open a case with Technical Support here:


If you click Reply, you will see there is an Attachments section below the area where you type your Forum post. Here you can browse to and add an attachment.

Have raised a support case.  Many thanks for your help.