Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
Visitor
Posts: 4
Registered: ‎10-19-2018
0
Accepted Solution

(1,2) but (1-3) citation

Hello!

I have a problem with a citation style. Is there any way to make a cictation in the following style: (1,2) but (1-3), i.e. comma separated for two numbers, but ' - ' separated for more than two numbers?

 

Many thanks..

 

P.S. I am using EndNote X9 with MS Word 2007, and edited ACS Nano style

Highlighted
Administrator
Posts: 653
Registered: ‎06-04-2008
0

Re: (1,2) but (1-3) citation

Hello Anton,

 

You should have been getting that format by default.

 

I have found and corrected an error in the style.

 

I will attach a zip file with the corrected style to this post.

 

You can download the file and unzip it. Once it is unzipped follow the steps below.

 



 Double-click on the file to open it in the EndNote software.

 Click the File menu in EndNote and select Save As.

 Click Save.

 Close the style window.

 You can now delete the original files the style has been added to EndNote.

 

I will also let our Content Team know about this error so they can correct the style and upload it to the website.

 

Thank you for bringing this issue to our attention.

 

Let us know if you have any questions or if this does not resolve the issue.

Best Regards,
Tony M.
Clarivate Analytics

Product Specialist
Phone: +1 800 336 4474
clarivate.com
Visit Customer Service – Get Help Now at https://support.clarivate.com for all your support needs.
Visitor
Posts: 4
Registered: ‎10-19-2018
0

Re: (1,2) but (1-3) citation

Dear Tony,

 

It works! Could you please tell me what actually have you changed in the style parameters window? I am using edited ACS Nano style, so I need to change only the (1-2) to (1,2) conversion. In other words, how can I adjust the citations in some new bibliographic style?

 

Thank you for your assistance

Mentor
Posts: 8,127
Registered: ‎04-10-2008
0

Re: (1,2) but (1-3) citation

Well, I was intrigued - so I compared Tony's modified version with the original - and there is a greyed out box in the citation number settings checked in the original and unchecked in Tony's (see attached) -- to uncheck that box, you need to first check the one above it (group citations), and then unckeck that second option (composite), then uncheck the grouped references again.  This is a strange bug.  When I did that on the original, it now correctly formats two consecutive citations with a comma and not a dash.  

 

(long time Endnote user)
Visitor
Posts: 4
Registered: ‎10-19-2018
0

Re: (1,2) but (1-3) citation

Dear Leanne,

 

I have carried out the steps you described - It really helps!

Thank you for joining to this dialogue, thanks to you and Tony for solving this problem!