Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 17
Registered: ‎04-18-2014
0
Accepted Solution

Auto-generated Bibliography Issues

HI,

 

I'm about to submit my PhD and I'm having formatting issues with my Bibliography being auto-generated by Endnote.

My Citation style is MLA.

 

These issues are:

 

  1. No Spaces between Author and Title

  2. Web URL not given even though it’s in my Endnote entry

  3. Removal of Capitalised letters in my Endnote entry

  4. Multiple entries from same author – should be ---, but Endnote is generating ---.

  5. Weird line breaks

I cannot see any obvious issues with my Endnote entries. I've attached a screenshot example of my Bibliography, highlighting some of the issues in yellow.

 

Would appreciate some help as I'm getting down to the wire...

 

Thanks

 

Darren

Mentor
Posts: 8,143
Registered: ‎04-10-2008
0

Re: Auto-generated Bibliography Issues

Where did you get the MLA output style and did you or someone else modify it?

 

If it is "out of the box" and unmodified, it looks like the problematic references are with specific reference types.  I see that the space is missing for Audiovisual Material in the MLA style (see image 1), which is probably the ref type you used for music CDs?  Spacing issues are probably due to the chosen ref type and empty fields being incorrectly "punctuated" and missing or incorrect application of the  "link adjacent" or "forced separation" characters. 

 

Which ref type is the Dairiki reference?  (extra period) and the title capitalization is a setting in the bibliography template too.  see image2.  I also changed that in the attached output style to "leave as is".  

 

so output style may need further tweaking, but here it is.  see if it fixes things.  remember you have to save this from Endnote (default setting) and then view the style lists and select the modified version in the word document on the endnote ribbon/toolbar.  

 

 

 

 

(long time Endnote user)
Mentor
Posts: 8,143
Registered: ‎04-10-2008
0

Re: Auto-generated Bibliography Issues

Just realized I missed a few... see if this works then remind me again what doesn't.  

 

(long time Endnote user)
Enthusiast
Posts: 17
Registered: ‎04-18-2014
0

Re: Auto-generated Bibliography Issues

Thanks will try it out today. 

 

Darren

Enthusiast
Posts: 17
Registered: ‎04-18-2014
0

Re: Auto-generated Bibliography Issues

Thank you very much Leanne, It's all looking good now. Here it is:

 

Many thanks

 

Darren

 

Mentor
Posts: 8,143
Registered: ‎04-10-2008
0

Re: Auto-generated Bibliography Issues

I didn't insert any URLs in the templates though, so your web URLs aren't listed.  Should they be in MLA?  surprising that none (maybe one did) of the electronic ref types include a URL in the biibliography?  

(long time Endnote user)