Showing results for 
Search instead for 
Do you mean 
Reply
Visitor
Posts: 4
Registered: ‎04-13-2010
0

Endnote automatically excluding year when reformatting (plus other problems!)

I'm having a bit of a nightmare with Endnote this week!  I would really appreciate some advice. 

 

I am using Endnote X.0.2 with Windows XP/Word 2002 at home. 

 

Problem #1: When I opened my file at work on Word 2007 and Endnote X3(?) the programme removed all the field codes despite using the same library.  How can I prevent this happening again or is there no way around this - do I just need to make sure I unformat before opening it?

 

Problem #2: When I got back onto my home computer I had to re-enter the field codes in the latest version of the document.  However when I did this, most came through without the year, even though I hadn't specified this.  Even now when I 'edit citation>'unclick Exclude Year' - it still removes the year if I then reformat.

 

Problem #3:  I enabled instant formatting, but now each time I unformat the document it sets this back to 'disable' automatically.  is this right?

 

Sorry to bombard you all but I'm  very frustrated and up against a deadline on my Literature Review.  I really don't want to go through all my citations again and edit them all to include the year and then have Endnote remove it again if I unformat.

 

Thanks in advance!

Guru
Posts: 677
Registered: ‎10-11-2008
0

Re: Endnote automatically excluding year when reformatting (plus other problems!)

I can't exactly reproduce your problem here, because I don't use Word 2007, but using Endnote X with Word 2003 and Endnote X3 with Word 2007 may be the reason you get all these inconsistent code managing. The best solution would be to upgrade the EN and Word at home, but I suspect that's not your option.

 

Formatting bibiliography is (mostly) dependent on the coding system (language used for macro) in Word, and the coding system between Word 2003 and Word 2007 are sometimes conflicting. Particularly, this becomes the worst case, when you do the "Edit citation" command, which deliberately remove year or author information from raw {author, year rec#} format.

 

As you've already reached some conclusions with good instinct, it is better to stay "unformatted" status when you migrate documents between two PCs. This is very true when multiple people collaborate. Also, I suggest to use "Edit citation" command at the last moment before the final document. That will reduce much troubles.

 

This sounds like suggesting very tedeous work flow, but we are dealing with two software with different versions. In a practical sense, even the work flow is tedeous, it should eliminate troubles and save your time in the end.

 

Instant format feature is automatically turned off every time you unformat the document, so that's normal.

Guru
Posts: 677
Registered: ‎10-11-2008
0

Re: Endnote automatically excluding year when reformatting (plus other problems!)

I'm adding to my own post, but just wanted to tell you one more thing.

 

When I write manuscript, grants, or any documents that have bibliography, I insert citations from Endnote, but I keep raw {author, year rec#} format until I feel comfortable to say "this is the final". I do not keep my document as "formatted'. In the middle of writing, I occasionally format my document depending on the output style, just to see how bibligraphy looks like, but I always bring it back to unformatted status. I really don't use instant formatting at all. This work flow became my routine, just to avoid troubles related to multiple computers (at home, lab, office, etc), multiple people, multiple EN/Word/OS versions. As long as you use a single computer at work, instant formatting is wonderful. But it's not for me. Most of the troubles of EN are related to CWYW feature (and plug-ins related). I'm pretty much sure about that.

Visitor
Posts: 4
Registered: ‎04-13-2010
0

Re: Endnote automatically excluding year when reformatting (plus other problems!)

Thank you very much, that's really helpful. 

 

I haven't had any problems with Endnote or CWYW in over four years so I guessed it was because I was suddenly starting to move between different formats.  I'll stay unformatted until the last minute and hope for the best.  This a 12,000 word document with a LOT of references so I really don't want to lose the fieldcodes again as it's a long job to replace them!

 

Thanks again. 

New User
Posts: 1
Registered: ‎11-06-2018
0

Re: Endnote automatically excluding year when reformatting (plus other problems!)

I kept having this exact problem and couldn't find help here in the forums or elsewhere. This is is how I finally ended up solving it. Just to recap, the problem is:

- Often when converting between reference styles or copy+paste between documents, the new in-text citations somehow change to "Exclude Year" as a kind of default in the Formatting. EndNote should have a setting where one can define the default, or so I thought.

 

The workaround:

 

- Select all text in the document, open the "Convert Citations and Bibliography" menu 

- Select "Convert to Unformatted Citations"

- You should now be able to see the {} field codes with the # reference to your EndNote library entry

- Select the Style you want to use and click on "Update Citations and Bibliography"

- Voila! (at least it worked for me, all my in-text citations now include the year)

 

I just saved an hour of tedious work editing every single citation (even after writing this here).

Time for a coffee.

Mentor
Posts: 7,930
Registered: ‎04-10-2008
0

Re: Endnote automatically excluding year when reformatting (plus other problems!)

If you never need to use the "hide" option, you can also turn off the setting in the preferences.  see attached.  

(long time Endnote user)