Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
User
Posts: 6
Registered: ‎03-22-2015
0
Accepted Solution

How to insert prefix before last in-text citation?

[ Edited ]

I know how to right-click -> Edit Citation -> More... -> Prefix/Suffix. And I thought the prefix/suffix could only be added at the very beginning or at the very end of the citation block. However I've seen from this other Endnote post (community.endnote.com/t5/EndNote-How-To/insert-text-in-citation/td-p/10426) that you can actually add a suffix to the first citation: the text is therefore after the first citation but before the semi-colon (this works for me). Like this:

 

(Devine, Forscher, Austin, & Cox, 2012 but also see, ; Lai et al., 2016).

 

But this is not correct because I want my text to go after the semi-colon and before the last citation. However when trying to add the same text in the prefix of the last citation, it goes all the way at the beginning of the whole citation block, like this:

 

(but also see, Devine, Forscher, Austin, & Cox, 2012; Lai et al., 2016).

 

This happens no matter which reference I select for the prefix, it always goes at the same place. The other problem I have is that in this case I don't want the references to be in alphabetical order: I want to cite the primary citation first, and then have the side note for the secondary citation.

 

Therefore, I would like to have something like this:

 

(Lai et al., 2016; but also see, Devine, Forscher, Austin, & Cox, 2012).

 

How can I do this? Thanks.

 

PS: I'm using APA style and Endnote version X7.8.

User
Posts: 6
Registered: ‎03-22-2015
0

Re: How to insert prefix before last in-text citation?

Update: In order to troubleshoot the problem, I've tested the functionality in a separate Word document with different citations, and it worked as expected (text before last citation). So I tried with the same citations, still worked. So what I tried was to delete and recreate the problematic/misbehaving citation in my main document, and then it worked! So it was clearly a bug.

 

As per the other problem of having once citation not following alphabetical order, the workaround is to use a stealthed citation and enter it again manually... (see: community.endnote.com/t5/EndNote-How-To/How-do-I-change-the-reference-order-within-a-single-citation/td-p/831)