Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 1
Registered: ‎06-17-2019
0

In-text citation error

Hi,

I have a library that contains both journal articles and internal reports, and I want the in-text citations to appear as follows: (Document number, Year) for reports and (Author, Year) for journal articles.

For reports, I have used the secondary author field (empty for articles) to enter the author, and left the author field blank.

I have written the in-text citation template as (Document number, Author, Year) and while the output is OK for journal articles (as the document number field is empty), it somehow renders (Document number, Title, Year) for internal reports... It's driving me mad! Is it because endnote doesn't accept an empty author field?

Does someone have a solution to this problem?

NB: I'd prefer not to use the author field to input the document number for our reports, as these numbers use spaces so part of the info would be lost in the in text citation that only uses last name.

Thanks in advance!

 

Administrator
Posts: 631
Registered: ‎06-04-2008
0

Re: In-text citation error

You need to used the Generic name of the field in the citation template which for Document number is Number.

 

You may also need to adjust the Anonymous Work setting in the style to Leave Author Blank since the setting it appears to be on is to use the Title field when a reference does not have an Author.

 

For additional help with output styles I would suggest that you contact Technical Support.

 

 

1-800-336-4474 option 4 then 1

 

or

 

https://endnote.com/contact/

 

 

We are here to help whenever you run into issues.

 

 

Best Regards,
Tony M.
Clarivate Analytics

Product Specialist
Phone: +1 800 336 4474
clarivate.com
Visit Customer Service – Get Help Now at https://support.clarivate.com for all your support needs.
Mentor
Posts: 8,096
Registered: ‎04-10-2008
0

Re: In-text citation error

You don't say which output style you are using, but you should check "anonymous works" settings which has replacements for what to do when the author is empty.  Perhaps you could use it to your advantage, and put the document number in the "short title" field?  see the image for the options.  I am not exactly sure what "Use APA specifications" does though. 

(long time Endnote user)
Mentor
Posts: 8,096
Registered: ‎04-10-2008
0

Re: In-text citation error

by the way, if you put a comma after the document number with the spaces in the author field, it will use the whole field and not just the part it might interpret as surname.  

 

(long time Endnote user)