Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
Visitor
Posts: 1
Registered: ‎09-15-2016
0

Setting in text citation format as default

I am using Endnote X7.7 for Mac.

 

I am using the Harvard referencing style which, as its default setting, should display a reference in text as:

 

author, date

 

However, I have added my references to my file and they have all been added as the exclude year format instead of the default and hence are given as:

 

author

 

I need my references with the date included. I appreciate that I can change each of my references manually from exclude year to default but I have 456 indivudal citations of 250 references and so this would likely take a very long time! Is there a way to set this?

 

I have checked the output style in Output Style Manager and as far as I can see there is no way to change this (although I have almost certainly missed something).

 

Any help would be massively appreciated.

Mentor
Posts: 8,088
Registered: ‎04-10-2008
0

Re: Setting in text citation format as default

[ Edited ]

I have never really figured out why or how that happens, but I have developed a solution that catches most variations apart from citations that have a prefix.  

 

First -- are there citations that you want to appear without the year or author?  If not -- at least on the PC version, there is a preferences option you can turn off, as shown in the attached image. (see the file "omit.jpg") That is the easiest way to have them all show again.  

 

But if you want to fix it for good, and retain the ability to occassionally omit author or year, then still remove the tick box from that preference, for now.   

 

Download and save (from Endnote) the attached output style Temporary-curly.ens.  Turn off instant formating.  And go into Endnote preferences and make sure that "omit" box is unchecked.  

 

Make a copy of your document.  

 

change the output style in the new document to Temporary-curly.ens  -- you will probably have to "Select another style" to see it after saving it (the first time).  

 

Update Citations and Bibliography.  

 

This will convert any endnote temporary citation to a "look alike" endnote temporary citation, and no reference list.  

 

Then you "convert to plain text" from the endnote ribbon (which forces you to create a new document).  Save the document to a new name.  

 

Now switch the output style back to your preferred format and update citations and bibliography.   As long as you have the original library with the original record numbers, the only things that will come up are citations you may have added prefix text.  Ignore those and then search for the remaining curly bracketed items and insert a \ in front of the author and update citations again.  You can now turn auto-formating back on.  

 

suffixes shouldn't be affected.

 

If you use cited pages -- you will need a further enhancement to the output style, but I haven't worked out all the bugs in that one yet.  I attach it, and I think it will work, but I haven't tested it thoroughly. 

 

 

(long time Endnote user)