Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 1
Registered: ‎07-24-2015
0

Unselecting reference types from the list (so they don't show up) within "edit output style"

I am currently setting up a reference style for a group that is about to publish a book togheter. I want to make some tweaks in a few of the reference styles, but my vision gets distracted by seeing all the styles that we never use in the window for "templates".

 

There is a list of styles in a drop down menue for the templates and it is fine to select the ones that are not selected, but it is not possible to unselec any of them. Seems to me like a glitch. By the way - I am working on paralells on a mac (windows 7) Endnote 7.3.1. I also tried to fix this via endnote x6 on the mac side...

 

 

please advise

Mentor
Posts: 8,101
Registered: ‎04-10-2008
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

[ Edited ]

(updated in 2018 I don't think my answer here was correct.  I was obviously misinterpreting the OP question to mean output styles).

 

I just delete what I don't want from the default styles folder on the PC in the program folder/endnote/style location.  Not sure where that is on the Mac though.  We have created an inhouse set of output styles that we have put on the server and replace the registry settings to point there.  

 

But if you view all styles, there a checkbox to uncheck (on the PC windows version) that you can deselect?  

(long time Endnote user)
Mentor
Posts: 2,087
Registered: ‎09-30-2009
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"


@Landgena wrote:

....There is a list of styles in a drop down menue for the templates and it is fine to select the ones that are not selected, but it is not possible to unselec any of them.....

 


Are you referring to an output style’s pull-down menu list of bibliography reference templates (see attached image)? Templates on the list that appear with an adjacent check mark indicate a pre-existing template already in use - so if you wish to make any changes you need to do so within that template. Or if you don’t need the template, then delete it and it should appear on the pull-down menu list without a check mark (indicating it’s not in use).

 

 

User
Posts: 6
Registered: ‎03-21-2018
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

I encountered exactly the same problem in X8 on Windows. Unable to uncheck any unwanted reference type on Bibliography>Template. Please help!

Mentor
Posts: 8,101
Registered: ‎04-10-2008
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

[ Edited ]

If you don't want a reference type to appear, you need to go to preferences>reference type and modify the name of the reference type to have a period at the front.  

 

Instructions from the help files in windows Endnote X8

 

To Hide an Unwanted Reference Type:

From the EndNoteEdit menu, select Preferences, select the Reference Type option in the list of preferences, and then click Modify Reference Types to open the Reference Types preference.

 

Use the drop-down list at the top to find the reference type that you want to hide.

 

Add a period before the reference type’s name in the column header to have EndNote remove that item from the Reference Type list in the Reference windows and elsewhere. The definition, however, remains in case you later wish to restore it by removing the period.

 

For example, if you were hiding the Map reference type, the column heading would be ".Map".

 

Click OK to return to the main Preferences window for Reference Types.

 

Click OKSave to save your changes.

 

(P.S. my original answer below was not addressing the true question! )

 

 

(long time Endnote user)
User
Posts: 6
Registered: ‎03-21-2018
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

Thank you Leanne for your advice and directing to the help menu which I obviously overlooked. I googled and some of the instructions provide the same solution.

 

However, this method failed. The attached file shows that it only adds a period in the actual name (see "hearing"). I suspect it might due to a different kind of period? I need to deal with a few languages and some of them are not Latin script based. But if this method just doesn't work then I should find other solutions instead of trying hundred types of periods.

 

Also, does this method works if I want to hide sections when I am editing references? Take "hearing" as an example again, if I do not want to see DOI when I am editing a reference, can I use a similar method to hide it? (I actually tried but it comes to show ".DOI" instead of hiding it.

 

Thanks again in advance and happy EndNoting!

Mentor
Posts: 8,101
Registered: ‎04-10-2008
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

[ Edited ]

You are correct, while the "dot" seems to prevent the ref type from appearing in the dropdown when you are assigning a ref type to records - it appears to be included in the ouput style's bibliography template's ref type dropdown list.  I don't know if that was always the case or a new "feature" after a update.  I agree it should not be an option.  

 

In the output style, if you remove the text from the ref type's bibliography template and save it, the template option will not be there when you open it again, unless you select it again from the dropdown and put something in it.  

 

Seems like one should be able to select and deselect it in the dropdown and see immediate response, but that doesn't appear to be the case.  You can never "disappear it" if there is text in it.  

 

 

 

sorry for the mis-direction.  

(long time Endnote user)
User
Posts: 6
Registered: ‎03-21-2018
0

Re: Unselecting reference types from the list (so they don't show up) within "edit output style"

Problem solved, thank you! Simply deleting texts from the bibliography template and save it then all things done. The panel (for me) is much cleaner now.