Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
Regular
Posts: 11
Registered: ‎12-31-2018
0

Avoid adding overrides to EndNote Bibliography paragraph style on update

This relates to EndNote X9 and the Cite As You Write plugin for MS Word.

 

It’s very nice and useful that EndNote creates a paragraph style named EndNote Bibliography in a Word document when adding a bibliography. Any bibliography should always have a paragraph style of its own applied, and it’s useful that EndNote automatically connects the bibliography to a paragraph style.

 

What is not nice – in fact, it’s extremely annoying – is that every time the bibliography is updated (i.e., every time you add or edit a formatted citation in the document), the entire bibliography gets manual overrides applied. In the Configure Bibliography → Layout options, I’ve managed to make the font stick so at least I don’t have to look at Calibri every time I update anything; but the indentation options don’t work. The paragraph style specifies a hanging indent, but no matter what I put in the indentation options (see attached screenshot), the end result is that there is no indent of any kind in the formatted bibliography. A manual override of “Left: 0 cm, First line: 0 cm” is always applied, which makes the bibliography impossible to navigate.

 

Removing these overrides is a fairly straightforward matter – just select the entire bibliography and re-apply the EndNote Bibliography style – but it’s very annoying to have to do this every time you add, edit or update anything.

 

Is there any way to change this frustrating behaviour to stop the plugin from applying any manual overrides to the paragraph style? Ideally, I would like to somehow tell the plugin to completely ignore the entire Configure Bibliography → Layout tab and all the options in it. Is this possible?

Mentor
Posts: 8,085
Registered: ‎04-10-2008
0

Re: Avoid adding overrides to EndNote Bibliography paragraph style on update

[ Edited ]

Yes,  For a brief time, the EndNote Bibliography Style editing "stuck" but every since X7.2 it gets overwritten.  Please software developers -- see if you can FIX THIS?  

 

On the hanging indents, Check your output style settings.  I find that while the format bibliography settings in MSWord will override the document settings, it may not override the specific settings of the style. So also check the settings in the Bibliography Layout section of the specific style you are using.  

 

I have a whole compendium of tips and tricks, some of which are way outdated at the beginning of this thread

(long time Endnote user)
Regular
Posts: 11
Registered: ‎12-31-2018
0

Re: Avoid adding overrides to EndNote Bibliography paragraph style on update

I just checked the Layout settings in the Output Style in EndNote – my indent option is set to “All paragraphs but first”.

 

I’m not sure if any of the options there actually make sense since each entry in the bibliography is, by definition, only one paragraph. I take it it’s just the word paragraph being misused to mean ‘line’ here, in which case “All [lines] but first” is exactly what I want (but can’t get).

Highlighted
Mentor
Posts: 8,085
Registered: ‎04-10-2008
0

Re: Avoid adding overrides to EndNote Bibliography paragraph style on update

The default option in preferences setting should be "all paragraphs"  which is what you want.  Once that is set, you can adjust  word's Endnote bibliography settings to adjust the amount of the hanging indent.    

 

 

(long time Endnote user)