Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 4
Registered: ‎11-17-2017
0
Accepted Solution

Book Section, comma problem (sometimes no Series)

Dear Community

After some try and error, I got most of my Endnote uses to work properly. But one problem I just seem to not be able to tackle.

The problem concerns a self-made output style of book sections. The books themselves are sometimes part of a series, sometimes not. If they are, there is no Problem. If they aren't, there is a comma missing (the one from behind the brackets, e.g. example). So my goal would be: If there is a Series Title and Volume, it should appear without a comma after the Year. If there isn't, there should be a comma after the Year and then Pages.

 

Examples as I want the output:

with series:

  • Shaw, Peter: The Life of a Second Detective, in: Hitchcock, Alfred (Hg.): Fictional Biographies of Americans, Rocky Beach 2006 (Fictional Biographies 6), S. 25-36.

 

no series:

  • Shaw, Peter: The Life of a Second Detective, in: Hitchcock, Alfred (Hg.): Fictional Biographies of Americans, Rocky Beach 2006, S. 25-36.

my coding:

  • Author: Title, in: Editor (Hg.): Book Title, Bd. Volume, Edition. Auflage, Place Published Year, (Series Title Series Volume), S. Pages.

However, with the red comma as it is, the title with series comes out like this:

  • Shaw, Peter: The Life of a Second Detective, in: Hitchcock, Alfred (Hg.): Fictional Biographies of Americans, Rocky Beach 2006, [<-- there should be no comma] (Fictional Biographies 6), S. 25-36.

And if I take it out of the code, the title without series comes out like this:

  • Shaw, Peter: The Life of a Second Detective, in: Hitchcock, Alfred (Hg.): Fictional Biographies of Americans, Rocky Beach 2006 [here should be a comma but isn't] S. 25-36.

 

Is it even possible to fix this? So make a Comma if no series and leave it out when there is series? (Connecting the Comma to the Series-brackets did not work out.)

 

Thanks a lot for your time and effort

Greetings

Moderator
Posts: 430
Registered: ‎06-04-2008
0

Re: Book Section, comma problem (sometimes no Series)

Please accept our apology for the delayed response.

 

So you would want to remove the comma after Year and then you would need to use the | forced separation characters around the (Series Title Series Volume) section.

 

So it would be | (Series Title Series Volume)|

 

If this does not resolve the issue then:

 

Please contact Technical Support directly


1-800-336-4474 option 4 then 1 or


https://support.clarivate.com/Endnote/s/technicalsupport?language=en_US

Best Regards,
Tony M.
Technical Support Representative RS
Clarivate Analytics
Formerly the IP & Science business of Thomson Reuters

Phone: +1 800 336 4474
clarivate.com
ipscience.tr.com

· · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · · ·
Mentor
Posts: 7,772
Registered: ‎04-10-2008
0

Re: Book Section, comma problem (sometimes no Series)

  • Author: Title, in: Editor (Hg.): Book Title, Bd. Volume, Edition. Auflage, Place Published Year| (Series Title Series Volume)|, S. Pages.

There may be other fields not filled in all cases which will need similar careful treatment though.  

(long time Endnote user)
Highlighted
New User
Posts: 4
Registered: ‎11-17-2017
0

Re: Book Section, comma problem (sometimes no Series)

Thank you very much, indeed it worked and made me aware of another template I had wrong.

You really helped me out! *thumbs up*

Grateful greetings