Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 2
Registered: ‎11-11-2020
0 Kudos

Problems with doi format in APA 7th

APA 7th edition requires DOIs to be presented as hyperlinks, i.e. beginning with https:// or http://.  The DOIs on the references in my EndNote library are a mix - some begin with https:// and some don't.  The EndNote APA 7th style is adding https:// to the front of all the DOIs, so that some are ending up with https:// twice on the front of the doi.   Is there any way to edit the APA style to only add this when it isn't there already?

Mentor
Posts: 8,625
Registered: ‎04-10-2008
0 Kudos

Re: Problems with doi format in APA 7th

I showed the DOI in the library view, sorted them, and then selected the http versions (and a few others that were older and had alternative data in them) and ran find updates on them in batches, and let the program update the fields, (as long as it didn't overwrite some of my custom fields).  

(long time Endnote user)
New User
Posts: 2
Registered: ‎11-11-2020
0 Kudos

Re: Problems with doi format in APA 7th

Thank you Leanne, that's helpful to know!  I will give that a try.  In the short term, I did a find/replace in Word once I'd converted all the citations to plain text, but I will need to get my EndNote library in line at some point.

New User
Posts: 2
Registered: ‎02-16-2021
0 Kudos

Re: Problems with doi format in APA 7th

I faced the same issue and fixed it within the EndNote library by running a 'Find and Replace' to find "http : //dx.doi.org/" (without the spaces) in the DOI field of references and replace it with nothing. This left me with only the actual DOI 10.whatever in that field and solved the double http issue Smiley Happy