Sitemap | EndNote
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 3
Registered: 4 weeks ago
0

Suffix for one citation not showing up

Hi!

 

I am trying to add the year of a second citation from the same author using the suffix field, but it does not show up.

I need to do it this way because the two citations are split by the citation from a different author (I use APA 6th ordered by year).

 

Example:

Automatic output:

First et al., 2015; Second et al., 2016; First et al., 2017

Desired output:

First et al., 2015, 2017; Second et al., 2016

 

I've tried to accomplish this by

1) set "First et al., 2017" to show in bibliography only

2) add ", 2017" as a suffix to "First et al., 2015"

 

I used this workaround before (in the same document even) and it works just fine. The same citation list has a prefix ("e.g.") which shows up. I tried to add the year to another citation in the list (e.g. "Second et al., 2016, 2017") and it does work fine as well. Is literally just this ione citation that seems not to allow this.

 

Other things I tried that did not work:

- Play around with the order of the citations in the editor panel (e.g. put the two citations from the same first author next to each other, at the end of the list) 

- Save, close, and reopen the Word document + EndNote

- Turn automatic formatting off/on

- Force the update of citations/bibliography

 

Any idea?

Mentor
Posts: 8,104
Registered: ‎04-10-2008
0

Re: Suffix for one citation not showing up

Did you include the necessary punctuation and space in the suffix field? sometimes these things happen because Endnote is trying to rationalize duplicate punctuation, having unexpected consequences.  

 

What does the citation look like in the unformatted version?  (the one that shows if you convert to unformatted citations?)  Should something like this (the ` before the suffix semi-colon is inserted by EndNote, to ensure it knows that this is part of a suffix and not the beginning of the next citation).  

 

{First, 2015, #RecNo or label`; 2017;Second, 2016, #RecNo; #RecNo}

 

P.S. Often what we think looks better but isn't consistent with the style, is not worth manipulating, as the publication guidelines are often correct, although not esthetically pleasing to us!

(long time Endnote user)
New User
Posts: 3
Registered: 4 weeks ago
0

Re: Suffix for one citation not showing up

Thanks for the response, but the formatting here is not the issue. Here's the real citation copied/pasted from word

 

{e.g. \Röder, 2002 #1229;Bedny, 2011 #1222;Burton, 2003 #1230;Lane, 2015 #1145;Amedi, 2003 #1231;Raz, 2005 #1232;Park, 2011 #1233;Lane, 2015 #1145`, 2017;Lane, 2017 #1228@@hidden;Kanjlia, 2016 #1146}

 

The bolded citations are the ones I'm talking about

Mentor
Posts: 8,104
Registered: ‎04-10-2008
0

Re: Suffix for one citation not showing up

yeah.  I never use the "hidden" (which I think is the "in bibliography only" option?) I use the hide author and year option, which just deletes the author and year from the unformatted citation and seems to be less finicky.  Not sure if that makes a difference.  

(long time Endnote user)
New User
Posts: 3
Registered: 4 weeks ago
0

Re: Suffix for one citation not showing up

I tried to change it to your way, as in practice "in bibliography only" and "exclude author & year" would accomplish the same goal, but it didn't solve the problem. The issue I think it's with the citationa I do want to show + add a suffix to it, rather than the one that gets hidden.

Highlighted
Mentor
Posts: 8,104
Registered: ‎04-10-2008
0

Re: Suffix for one citation not showing up

If it works for one, but not another, make sure there isn't something funny with the first citation, a random space at the end of the author name or try adding another space in the suffix to see if you can override it?  Does it contain diacritics?  

(long time Endnote user)