Author with apostrophe in name is not put in correct order in bibliography in APA 6th

Endnote puts


before Dahlvig

in bibliography

I have tried excluding the apostrophe and leaving a space after the apostrophe, but these names remain out of alphabetical order in the bibliography.

Any suggestions?

Try treating the name as a corporation by abbreviating the first name to an initial followed by a period and a comma. So in the Author field the name should be entered as:

d’Arbon, D.,

Since the  author’s first name is abbreviated suggest you  store  the author’s complete name in another field  such as  “Research  Notes”  for your reference.

Tested CGs trick, and that doesn’t work unfortunately.  In fact if I have both the comma trailing and the original record, endnote views them as the same and removes one as a duplicate.  

The endnote help file says that, in every field apart from title, that punctuation is alphabetized first which obviously contravenes the APA rules which specifies to ignore spaces, hyphens, apostrophes, etc.  Surprisingly this doesn’t appear to apply in the way the Endnote library itself is sorted in the display though!  

In the library view, d<space>Arbon, A is sorted before Daar, and the other three (d’Arbon, A; dArbon, A; d’Arbon, A<trailing comma>) are sorted together after Dann and before Darn in my library.  In the document, dArbon is sorted in the correct place between Dann and Darn, but the other three are sorted before Daar.  So there is no systematic treatment of these variations between the bibliography and the library view system of sorting.

I even tried changing the Bibliography sort “other” settings from “system” to use French, Norwegian and English to see if one of those would ignore the puctuation.  – no difference.  

I can only see getting around it, by removing the apostrophe, which means you need to remove field codes and do a search and replace before submitting to restore it.  

You should also report this to the developers (perhaps with a short note in Suggestions formum pointing to this thread?)  I can’t believe it hasn’t been noticed before!?