EndNote 8.1 seriously slow on MacOS 10.13

I am not sure what is going on, but EndNote 8.1 is basically unusable with MacOS 10.13. I see the spinning color wheel which is associated with freezes on the Mac every few seconds as I try to select, sort, and remove references in different groups. It is just maddeningly slow. I tried creating a fresh library and turning off syncing. It didn’t help. I ended up shutting down and booting into Windows to use EndNote that way. It was much more responsive. Please fix EndNote for Mac!!! It is not in good shape.

I have the same problem. Has anyone found a sollution? Can EndNote be reinstalled in any way?

Exactly the same problem here… 

Dang, I just posted about this problem in another thread. Running OS X 10.11.6 and getting the beachball every time I try to modify an entry, when I didn’t have the problem with x6.

I would go back to using x6, but I have to collaborate with a new user who’s running x8 and the libraries are not compatible. If I can find an x6 license I’ll have to have him install the old version.

Upgraded to 10.13.1 this morning and ran some tests with a stopwatch. Still getting the same problem with build 12930 of EndNote x8.

Once I change the case of a title to sentence case, hit save, and try to click on another citation, it’s 10-12 seconds of inactivity and beachball before the selection field changes.

In EndNote x6 build 8318 the process is almost instantaneous on the same machine.

I’ve found that occasionally closing EndNote and restarting brings back the responsiveness.  Not a true fix but it is a workaround.

Running macOS 10.13.1 / Word 2016 15.4 / EndNote 8.1



update to 10.13.2 problem solved !!!

Thanks for the heads up! I can also confirm that updating to 10.13.2 solved my problems. Thank goodness! I assume it was something on Apple’s end causing the problem.

10.13.2 seems to have solved the problem for me, but unfortunately not for the person I’ve shared the library with, despite upgrading his laptop from Sierra to High Sierra.

EndNote X8 is brutally slow on my 2017 MacBook Pro running 10.13.2. The spinning beachball is a constant presence. This bug has been in place since I upgraded to EndNote X8, and occured with OS 10.12 as well. I’ve switched my default PDF handler from Acrobat to Preview, to no avail. EndNote X8 is nearly unusable in its current incarnation. I am testing Zotero and Mendeley, and plan to switch if either suits my needs. 

I can confirm that 10.13.2 does not always solve the problem. My lab upgraded from Sierra to High Sierra (directly to 10.13.2) and EndNote has become unusable for several users in the manner described above.

I have the same problem!!! Please we need some indications to improve EndNote X8 usability in Mac High Sierra!!!

I reported this problem to Clarivate technical support, as my installation of Endnote had become unusably slow. They suggested that upgrading MacOS to the latest version of High Sierra (10.13.3) (I had previously upgaded to the latest version of Endnote X8.2 and it was still very slow) and this combination resolves the problem. Now Endnote functions as I would expect it to, Wow, night and day! Endnote is usable again. 

Still ridiculously slow on my mac. I’m running 10.13.3 and the latest EndNote 8 update. It’s garbage for me right now. I am on my 30-day trial. I used to use EndNote X7, so I figured I’d take this one for a spin. I won’t be buying it if this is what it’s going to be like while writing my thesis. I’ll go with Zotero or something else, even if they’re not as good. This is absolutely useless to work with for how expensive it is. Takes up to 90 seconds to update, even when I’m just removing some artifacts from exporting citations from my university’s website. 90 seconds to remove the word “NEW YORK”?!

Our workaround was to install a virtual Windows machine on my student worker’s Macbook Pro (2017) and running the Windows version of EndNote… It seems to run at full speed now.

I did test out Mendeley, which seemed very promising, but there’s no way to replicate our existing folder assignments without manually reassigning every publication.

Same problem here. I tried a new library and with only three references, only one of which has a PDF attached to it, there is a several second lag when switching between references (spinning beach ball and all). This is on both a pretty new (last year) MacBook Pro and a slightly older iMac, so computing resouces should not be a problem.

This is a great shame as it renders EndNote completely unusable in practice. And as far as I know EndNote is the only cross-platform reference management that allows for easy editing of citation formats (I know you can edit CSLs as used by Zotero and others, but that process is far from intuitive).

Longtime Endnote/Mac user here (15+ years). Was forced into upgrading to X8 (from X7) when I updated Word 16 and found that this borked X7. $100 later, I also am finding X8.2 (build 13302) painfully slow under 10.13.3 (running on a 2013 13" Macbook Pro, 16 GB RAM). Every click on a new reference in my library is 5-10 sec of spinning disk wait time. Every click between my library and the PubMed is likewise slow. I suspect that the delay has to do with the new cloud-based library storage, which clearly is being pushed by the developers, but which I neither need nor want. If this doesn’t get resolved, I will have to switch to another biobliography app.

The slowness started about a week ago for me, and now I have a damaged library.  Back up your library and take a look at the “your library is be accessed by another user” error.  I’d be willing to bet that’s what will happen next.   Grrrrr

Me too. Reported this ages ago and it was dismissed as a “MacOS bug that needs to be resolved by Apple.” Kicking the can down the road. As an Apple seed tester, I don’t deny there are issues with macOS (I’m currently running 10.13.4, but EN8 has been nearly unusuable for months now) but I’m not seeing anything like this with any other software I use. This is truly an EndNote 8 issue and nothing I’ve tried (using a test library, for one) helped. It starts off ok and within minutes triggers a beachball with every click.

Please fix this.

I contacted Clarivate tech support and was given the same answer: a Mac problem with annotated pdfs. It’s a bit hard to believe this however as I have very few of these and the entire app works as others describe: move a reference to anohter folder? see the beach ball and wait three minutes watch endnote crash, reopen repeat. I’m working on a project right now where I need to organize hundreds of citations for coding and endnote (after 15 years of use) is UNUSABLE!! Please please fix this!