Error received

 tried the beat of IE9, and ENW wouldn’t run right.  So I went back to IE8, and tried re-installing ENW, but I keep getting the error in the attachment.

What do I need to do to fix it and get ENW working right?


Chuck Billow
EndNote Error.jpg

Hello Chuck,

Can you confirm what OS you are using? Also, if you move, or backup and delete, this folder (C:\Program Files\Common Files\MSSoap) and try to re-install, does the error go away?

  • Mathilda, the EndNote team

Mathilda, I’m using Windows 7, and that folder was entirely deleted during the uninstall, and still no luck.  There’s obviously a piece somewhere that is unaccounted for in both the EN uninstall, and also using an uninstaller a hidden piece?).


This may be more of a Microsoft (IE9/Windows 7/SOAPISAP.dll) issue than EndNote so have you considered  querying Microsoft’s  support by phone or email:

Also was curious about the following:

  1. Can you rollback (i.e., restore point) your system’s settings to a point predating the time you installed IE9 beta?  Or do you have a backup image of your hard drive that pre-dates the IE9 installation?  Either could be used to fix your operating system.

  2. If you don’t have a restore point or backup image, the last resort is to use a recovery disc to restore your computer to factory settings. 

In both situations (1 and 2) you should first backup copies of documents, email, and other vital folders or files as rolling back or re-imaging a hard drive will overwrite the current files/folders/settings on the hard drive.

…just some thoughts.


If this were a IE9/Windows 7/SOAPISAP.dll issue, then:

If it were a Windows 7 issue, it would have popped up before IE9, yes/

If it is an IE9 SOAPISAP.dll issue, shouldn’t it have been fixed by the uninstall? 

In either case, is it looking like it is just that file?  For if so, could I just recover that one file (in case it was not restored on the uninstall properly?

As for the backup, except for a couple detains, I ran a backup just before I installed IE9, so I could if need be go back to that.

If this is a Windows7 or SOAPISAP.dll issue, shouldn’t it be showing up for someone besides just me?  Or, if nobody but me tried IE9 yet, and it I an IE9 issue, wouldn’t it or shouldn’t it be something the ENW should at some point find in their testing?


Chuck Billow

A check of the postings related to IE9 on the Microsoft’s site seems to indicate other users have/are experiencing problems.  It will be interesting to hear from other EndNote users who may have experienced the same problem as you.

While the beta IE9 may be the main problem, I’d be concerned that the installation/removal (unless performed per Microsoft’s tech notes: might have affected the registry.  Hard to say but what is known is you’re definitely having problems.

It looks like it might just be the SOAPISAP.dll file but the odd thing is you’re unable to locate the MSSoap\Binaries\ folder so it’s unknown whether they contained other files besides the .dll - in which case installing the .dll alone may not offer a fix.

For these reasons it seems prudent to contact Microsoft OR restore your hard drive with the backup file.  NOTE:  When you performed the backup, the resulting file should have included your entire computer (includiung the operating system) and not just documents, email, images, etc.).

Since others at the Microsoft site and some tech forums have noted problems with beta IE9 presumably Microsoft will address that (hopefully) before the final release. Would think EndNote developers are testing IE9 as well to ensure it works properly with EndNote Web but this sort of discussion is far beyond the users.  

The onus is on Microsoft to fix IE9 but my personal option is that on a customer service basis it might be helpful for EndNote support people to be able to offer some type of workaround or fix, how much does EndNote owe to users who install beta software from other companies remains to be seen.   It’s also a cautionary reminder to users about the possible pitfalls in downloading beta software and the need to have a backup plan (e.g., restore point, image of the hard drive) to be able to reverse any problems caused by the installation.

Just my 2 cents.  :wink:


I hear and agree totally.  My problem at this point is that I restored my system to pre-IE9, and am now still getting the same error.

Before trying the install, I checked and it didn’t seem the ENW was installed as yet.

** But I got it to work fine at one point, so why, with the backup, can’t I repeat that??

What’s extra-aggravating is that the error is an “unable to register” error, but when I tried to register the dll separately it wouldn’t then either!




I finished the restore and am back to IE8.  The install of ENW seemed to go fine;  I’m still getting the “Class not registered” error when I go to the ENW site to log in, but it does go there.

Very strange…



Restoring the hard drive with a backup at a point where everything ran smoothly is a reliable way to return the computer back to working order.  (This assumes, however, that the backup is reliable and does not contain errors.) 

It’s very odd that the error message still occurs post-recovery (backup) although could you explain what you meant by “register[ing] the dll” as it seems like you did something more than just restore the hard drive and install EndNote.

In any event, suggest you consider a two-prong inquiry to tech support (Microsoft and EndNote) to resolve the problem.

Our messages overlapped but this is good news - glad your system is nearing normal operations.

1 Like


Just to double-check, I logged in, added a site, and logged out, then, just now, I logged in and the site was still there.  So it seems to be working.

Strangely, I get the same
“Class not registered” on every login.


But as you note, at leasSt it’s making progress.



Is there a solution for this? I am experiencing exactly the same error with installing EndNoteWeb. My system is Windows 7 64 bit edition, using MS Office Word 2010 32 bit edition and IE 8. I’m on a Mac using the Bootcamp partition.

Please see attached.

With thanks,


In my case I found that removing EndnoteWeb with the installer, then reinstalling solved the problem.


Still getting the “Class not registered” error – but then it starts up ENW.

And I do NOT get the error in Firefox, only in IE8.


Chuck Billow

Can’t say for certain but “Class not registered” might suggest not all files associated with the application may have been installed. If you’ve hit the wall on this, tech support is always an option.  But if you elect to go another suggest you remove IE8 and EndNote (a complete removal), then restart your computer, then install the two programs again IE8 first, then EndNote).

Okay G, thanks.