Formatting edited collections in Endnote 20

Hi there,

The following edited collection is presented in my bibliography as the following.

Photographs objects histories: On the materiality of images. Material cultures. Edited by Elizabeth Edwards and Janice Hart. London: Routledge, 2004.

I’d however like it to show as 

Edwards, Elizabeth, and Janice Hart, eds. Photographs objects histories: on the materiality of images. London: Routledge, 2004.

The style sheet for an edited collection is set as follows:

Editor, ed.^eds. Title|. Edited by Series Editor|. Edition ed|. Number of Volumes vols.| Vol. Volume|, Series Title|, vol. Series Volume|. Place Published|: Publisher|, Year|. Reprint, Reprint Edition|.

Edwards and Hart are listed in the Editors field of the record.

Any help on how I can format to show differently would be much appreciated. :slight_smile:

Is the record correctly matching the  Reference Type as the template you copied below?  It looks like it is using a “book section” order of fields rather than an “edited book” ref type.  Which output style are you using?  

 No it’s not - thank you so much for flagging. I’d tried everything else, but not the obvious - thank you SO much.

Hi again,

I’m now having problems including multiple editors when I’m citing a chapter in a book which has mutliple editors. I give an example in the attached screenshots. Do you have any advice on how I can show mutliple editors?

Also, when I’m citing two page numbers, like 145 and 154, why on the second occassion does the reference drop the 1?

Thanks for your help

Not sure I can identify all the issues you are having.

Are these all footnotes? 

What output style are you using? (I can see that your are)  I assume you are using the book section as the reference type?  

In image 15.47.26 are you  putting the number into the cited pages field and it is missing between the brackets?  not sure what you mean the reference drops the 1?  

In image 15.47.38
The Author fields should both be entered as, 

   Kingstone, Helen 

   Lister, Kate 

or Endnote will assume that Kingstone is the first name, for example without the comma. 

But that isn’t the editor field.  The editor settings are separate from those of the primary authors (they are secondary authors) so check the Author lists and Editor lists setting in both the footnote and/or the bibliography template settings.  

in image 15.48.09

I think that endnote has always had a bug in how it handles page numbers.  If the output style defines conventional page numbers as being shortened from 145-154 to 145-54, then it seems to affect cited pages in the same way.  I would change the output style selection for page number to do not change highlighted in the attached image.  

Thanks for your quick response. It turned out I was doing all that you said. Many of the references I was having problems with were imported with Zotero. When I re-added them again directly into EndNote, they worked as you advised.  Thanks for your help :slight_smile:

1 Like