How to change WOS URL into valid proxy server

When I import Web of Science references into the EndNote X.7 Desktop, they import with a funky URL that looks like this: <Go to ISI>://WOS:000320030100057   This funky URL does not work from off campus. How can I change settings to create a useful URL import into EndNote that incorporates my university’s proxy server?

Please do NOT suggest that I change Preferences to tack on the proxy server prefix. All other databases work correctly now with the proxy server in EndNote. If I make that change, it will mess up the URLs of the other databases.

I can manually paste in the proxy server prefix URL but that is tedious.

By the way, I saw two previous Posts with this same question but no replies/solutions.