Help! I am working on a final project in EndNote and while trying to edit an entry the entire website switched into Japanese. I don’t know how to switch it back. All I did was double click on the entry. Any ideas? I don’t see a language option (google is helping me translate the page).  

Is this because google thinks you are someplace else?  I had this happen when I was in Okinawa.  This helped https://support.google.com/websearch/answer/873?hl=en   (at the very end).