Blank Endnote Registration window

I’m using EndNote 7.2.1 on OS X 10.9.5. I recently enabled the sync functionality, which seems to mostly work, but on most syncs I get a large dialog box titled “EndNote Registration”, which looks like it should contain text (perhaps loaded from an embedded browser?) but there is no text in the dialog (screenshot attached). At the bottom are two buttons: Cancel and Sync. If I click Sync, things progress, but sometimes I get the dialog a second time during the sync process.

I’m guessing there is some aspect of my EndNote Online account that makes EndNote think I need to complete some registration, but since the content doesn’t display, I don’t know what the problem is or how I would resolve it.


I do apologize for the problematic behavior that you’ve encountered.  Try these exact steps to see if you’re taken to a populated registration window:

1.  Launch EndNote X7.

2.  Open the desired library that you would like to associate with EndNoteSync.

3.  Ensure you’ve got a backup copy of this library, just in case.

4.  In EndNote, click “Tools>Sync”.

5.  Even if you’ve got an existing EndNote online account, click the “Sign Up” button.

6.  Input the email address that you want to use to log into EndNote online.  If you’ve already got an EndNote online account, use the same email address.

As you progress through this process, I suspect you’ll be taken to a populated registration window.  Please let me know if that is not the case by replying to this forum thread.

Thanks Jimmy! I had to go to Preferences->Sync and then click the Enable Sync button to get a dialog with the Sign Up button, but then used my existing account info and it now seems to sync without any dialog prompt.

1 Like

Glad to hear that you were able to overcome this challenge!  Definitely let us know if you encounter any other difficulties.


I’m encountering the same problem, so I tried following the same instructions, but I’m getting the following error message “The page you are viewing is not a valid EndNote Sync Activation page.  There may be a problem with the server.  Please try again later.” (see attached screenshot).

I’m using EndNote X7.5 (Bld 11052) on OS X 10.11.3 El Capitan in a rMBP 13" Early 2013.

Obviously, I tried it a couple of times before posting here.

Any ideas???

Greetings bageragr,

I’ve just created a Technical Support case for further troubleshooting and have emailed you directly.  If you don’t receive the mentioned email message, please let me know by replying to this forum thread.

I have the same problem, any fix for this?

I’m getting the same error, any fix for this?

Try again?  I think they were updating the server over the weekend. 

Thanks, I did. The problem is not the availability of the server, its that the registration window is blank. The same problem that bageragr was facing. If I click the signup button in the settings, it takes me to a populated registration page but gives a message that the registration page is not the correct one. The settings then terminate. 

Any ideas?

I would try to go from  – login (upper right corner) and create and account from there?  I just did that - and had no problems.    

I can log into my trial account online, but not through the licensed version of endnote through the app. Since the app doesn’t allow me to do this currently, I cannot use the unlimited storage that comes with the licensed version.

I recommend you contact tech support at or a moderator may reach out to you, now that the holiday is over?  I have no problem from the edit Preferences>sync window getting to the registration window.  Is it possible there is a firewall in place preventing endnote from getting thru?  


I am having the same isssue.  I tried to sign up again but I get the message “the serial number has already been used…”.  It is really frustrating to have the blank registration window popping up every 15 minutes.  

Greetings siegeman12,

I’ve created a new support case for further troubleshooting and you should have already received a direct email from me.  If you don’t see the mentioned message, please reply to this forum thread to let me know.

Dear fellow users,

I also always received the blank window. (OSX 10.12.5; EndNote 8.0.1)

I solved my problem with those steps:

  1. Go to “Endnote preferences” (“EndNote” -> “Preferences” or: “cmd” + “,” )
  2. go to “Sync”
  3. klick “EndNote defaults” & close the window
  4. go to “Tools” -> “Sync”
  5. hit the “Sign up” button no matter if you already registered with this account
  6. sign in with your account email + password
  7. et voila: sync was now working fine for me without a blank window which disrupts the syncing progress.

best regrads!

1 Like

This worked for me for both EndNote X9 and EndNote 20. Thanks!