Can't get citations to insert into Apple Pages 09

Hi all,

I have had a bit of a break from work due to ill health and I am starting to slowly get back into work. I have purchased a new iMac at the begining of the year (its now running Mountain Lion). I have installed my version of EndNote x4 onto it. I have imported my library and in EndNote everything seems to be as I would expect to see. I have also installed Pages 09, including the plug-in from Apple’s website.

Whenever I try and add in a citation, it brings up the ‘cite whlie you write’ box (having tried both the keyboard short cut as well as the more long winded insert, endnote citation) allowing me to see my EndNote library. But when I highlight the one I want and click on insert, nothing gets inserted, there maybe a blank space as some sort of marker, but nothing is visible. When I scroll down to the bibliography on the next page it says “The bibliography is empty because the document has no citations. To add a citation, choose Insert > EndNote Citation.

There maybe something basic I have not done - its been a while. Any help and guidence would be very much appreciated.

Many thanks in advance

So after getting maddly frustrated with it, I restarted my iMac and tried again - low and behold it has seemingly started to work as I would expect! Fingers crossed this continues.

I am having the same problem using EndNote X6, Pages 09, and OS 10.8.2.  EndNote allows me to select the reference of interest, although the insert button remains white, implying that it is not active.  It does respond, but EndNote inserts only a blank space.  The space cannot be deleted until one hits the delete key twice.

I have restarted the Mac, but that did not help.

Check what style you are using?   You may be using a footnote style which doesn’t insert a citation (the output styles’s citation template is empty, while the footnote templates contain the informatin that woudl be inserted into the footnote).   Does the bibliography populate?  If so, this is the likely cause.  Otherwise, I would suggest discussing this with tech support. 

Thank you for your suggestion.  A legitimate output style is selected, although I cannot find anything informative in EndNote relative to footnote styles.  I am not using footnotes.  A bibliography is created; however, it says that it contains no references and advises me to use Insert>EndNote Citation to populate the Bibliography.  Of course, then it also refuses to put anything into the Bibliography.  

X6 seems to have a number of problems.  It refused to launch initially because it could not index the PDFs.  Tech support advised me to remove the PDF folder and then re-load them a few at a time in order to locate the offending PDF file.  As it turned out, there never was one.  Once I got them all loaded again, it worked.  X6 also inactivated about half of my smart groups, and I had to delete them and re-create them one at a time.  Now they all work, but X6 has wasted a lot of my time so far.

Hey i got a solution for you, just pick the footnote then see on the right side, beside text tab is Footnotes then choosing section Endnotes on the type tab.

i hope it would help !!!