EndNote libraries 1) getting corrupted when I move them 2) mysteriously going back in time

Hi, I kind of doubt anything can be done about this problem, but I want to see if anyone else has had a similar experience or has a possible explanation for what happened to my EndNote library.

The short version of the story is that, one day, I opened my EndNote library that I’ve been using and adding to for several years, and it had several hundred fewer references than it was supposed to. In fact, it appeared to be identical to a version I used 3 years ago, when I moved to my current institution.

The longer version of the story is that, 3 years ago I moved from University X to University Y for a post-doc position. I had been using EndNote 8 at U. X. I copied all my files, including the EndNote library and associated DATA folder, onto a CD to bring them with me. Once set up at U. Y, I installed EndNote 8 on my new computer, copied all the files from my CD, and tried to open and use my EndNote library. EndNote would crash every time I tried to open the file. An IT person worked with me on this issue and got a copy of my library to open on her computer, so she made me a copy of that file, but that copy also crashed EndNote each time I opened it. Finally after weeks of tinkering she got it to work for me. I’m not even sure what she did to finally get it to work- she had exhausted suggestions from online forums and was just going on trial and error. So I had my library in EndNote 8. Later, I upgraded to EndNote X.0.2, which I currently use. I had the most recent version of my library on the desktop on my C drive, and I had back-ups elsewhere in the C drive, in 2 different places. Then one day a couple of months ago, I went to use the library- my “main” copy on the desktop - and it was gone. The icon was simply not there. I went to my first backup, and it was, as I described, the version I had had when I moved to University Y – 3 years ago! Fortunately I had the second backup, but I hadn’t updated it in ~ 6 months, so I still lost 6 months of changes I’d made to the library, which is still pretty frustrating, though not as devastating as losing 3 years of data.

My current IT person (different than the first one, who left) is baffled and has no suggestions. Anyone else have disappearing or “time-traveling” libraries? What could possibly cause this? Any idea how to avoid this in the future?

I am now about to move to a new university again, and I want to avoid any problems moving my library. I am afraid that if I try to transfer it on a CD or flash drive, the file will become corrupted or will crash EndNote when I try to use it at my new institution. Any advice or suggestions would be very welcome!

Thank you,


Have you had any luck finding out the problem?  I have had a couple problems, the first one is that I had a library that was located on the hard drive I then compressed the library to an external drive for a back up copy.  Then I started using the library off the external drive and when I compressed it back to the hard drive - it said that it compressed, but when I opened the library, there were no files.  This has happened several times.  Then when I went back to the library on the external and opened it, I lost over 200 files.  I was just about done reinserting those lost 200 files when it happened again and this time it was 249 files that disappeared and when I went to get the back up copy that I had made it was empty!  I can no longer compress the library to my hard drive or even copy the files from the external to the hard drive, it says it is there but when opened the library is empty.  I tried using two external drives and the same thing has happened, it won’t compress out right and when copied over sometimes it works and sometimes it doesn’t.  Very unpredicable at this time and scary, I can’t afford to keep losing files.  So if you have any suggestions that would be greatly appreciated.

Without being able to look at your computer, I am guessing that the copy problem might have to do with the file name length problem.  Remember that the PDF are pretty far down a directory tree.  If the library has a longish name, if you gave attached PDFs a longish name, and you are trying to uncompress the library in a deeper level folder (or on the desktop, which means it is saved to a user folder on C:) is somewhat deep in a directory tree, the file names of PDF with the path can get pretty long, and Endnote/Windows doesn’t always give an error message.  The max the Windows operating system allows in a name is something like 250 characters, and that includes the directory/folder names. 

See http://community.thomsonreuters.com/ts/board/message?board.id=en-howto&message.id=2488 for a similar problem. 

I was running EN5, and updated to EN7 with library on external USB drive. After I used EN7 first time my library became damaged. I cannot open with neither EN5 or EN7, I tried the recover library tool in both EN5 and EN7, aftrer wainting a long time I get the message 0-references recovered. For F***!!! sake how can this be such an unserious product? I lost 2000 references, you are wasting my time! F***! F***! F***! :manmad:

Did you just copy the .enl file?  That isn’t what you need.  You need the entire .DATA folder too.