Library damaged error message


after a while any of my libraries are opened (it happens with ANY library), I get the message “This library appears to be damaged. Please verify that no other user has this library open simultaneously with write access. If this error persists after restarting Endnote, please repair the library using the “Recover Library” command on the “Tools” menu.”
I did restart and the error happened again. I did recover the library (tried different libraries, and still get the error.
No one else, no other programs are using the library. I even checked with a program like “unlocker” and no other program is accessing the library.
can you help please?


1 Like

Where are your libraries located (hard drive, dropbox, cloud, server, etc)? 

Can you open the library by opening endnote first and then from there, open the library, rather than double clicking? 

1 Like

hard drive

I open Endnote (i.e. not clickin on library), the libraries open. It’s only after a while (1 hour?) that I get the error message and the only solution is to kill the Endnote task in Task Manager

1 Like

Were the libraries ever renamed? The library consists of a file and a folder. If your library were called My References you would have a file called “My References.ENL” and a folder called “My References.DATA.” The names of the file and folder must match exactly.

Where on the hard drive are your libraries located? If the libraries are in the Program Files or Program Files (X86) folder you will have problems with the library. This is a restricted area in the newer versions of Windows.

Are the libraries located in a folder that is set to be synchronized or backed up? Synchronization or backup programs can sometimes modify the contents of the RDB folder, which is inside the DATA folder of the library and cause the library to become corrupt.

1 Like

In short, if you use Dropbox, Google Drive or Sharepoint or another syncing program, that is likely the problem.

A. Move your EndNote database folder away from Dropbox and Google Drive, and back up your data using Endnote Web syncing.


B. Right click on the Dropbox (great) or Google Drive (evil) or Sharepoint (not as evil, Office 365 rocks!) icons and pause syncing while using EndNote. 

More details and a digression:

Jason from Endnote Tech Support explained that the similar problem I have been reporting ever since Endnote 5 (perhaps even 4) is likely related to my using Dropbox and/or Google Drive.  He explained that when you work in Endnote, there are updates made to the various MySQL databases found in the RDB folders with the DATA folder that is created with an identical name to your endnote *.enl file.  These databases end with *.myd or *.myi extensions. 

Even if you don’t have PDF attachments to your records, the various indexes and such are stored there in the /*.DATA/RDB folder.  What happens is that when Dropbox or Google Drive or any other syncing program (such as the program which I highly recommend for periodic backups to removalbe media) syncs the changes on the hard drive to the Dropbox or Google Docs in the Cloud, Endnote may also be simultaneously trying to make a change that requires updating the MySQL file.  This can and does reliably corrupt those files.  So it’s note really your “database” that is corrupt; no need to have a hard attack!

Anyway, for a couple of years now this would happen constantly, and the only explantion I would receive was that I shouldn’t open the databases by clicking on them; use File/Open instead I was told about a year ago.  But it kept happening.  Apparently, however, Endnote figured out just about a year ago what was happening with Dropbox reported that this was happening with MySQL databases in many applications, not just EndNote.  The solution(s) are simple:

A. Move your EndNote database folder away from Dropbox and Google Drive, and back up your data using Endnote Web syncing.


B. Right click on the Dropbox (great) or Google Drive (evil) or Sharepoint (not as evil, Office 365 rocks!) icons and pause syncing while using EndNote. 

P.s. Did I mention Google was evil?  Google Drive will permit pausing, but once you have paused it will no longer respond to right clicking!  I mean, why expect Google to produce a useable application, they rule the universe, why bother with users.  So you end up having to Control/Alf/Delete and stop the process and who knows when it will start again; most likely next time I re-boot.  Google is evil because for instance it first allowed you to have Google Docs but then practically forces you to download it’s substandard application; it wants to own your hard drive you see.

1 Like

My library is not in Dropbox or similar.

I suspect the problem comes from my backup software. I could ignore the library folder from the backups, but then that means I lose everything in the library if the computer crashes (I have 1.8Gb worth of PDFs!).

I could use Endnote Web. but will it back up the PDFs too? again, this would be very recource consuming as my library is 1.8Gb.


1 Like

If you have an EndNote Web premium account associated with EndNote version X5 or later of the desktop software, you can transfer or Synchronize (with EndNote X6) your file attachments:

Jason Berman
Technical Sup Rep RS

Thomson Reuters

Phone: +1 800-336-4474

1 Like

I just started having this problem today.  I don’t have a backup program setup.  Are there are possible causes?


1 Like

I figured out that settings from iolo System Mechanic was creating the problem.  Hope this helps someone.

1 Like

Thank you for that update, malachirobertso. If you can provide more information on which settings of the “System Mechanic” were causing the issue, it may be helpful for other EndNote users.

Thanks again,

1 Like

I ran into this error too using Endnote X5…presumably because I had my library stored in dropbox. The fix was pretty simple:

  1. Rename the corrupt .enl file to anything else

  2. Open it with Endnote, clicking past the error message that tells you there is no .data folder associated with the library.

  3. Endnote creates a new empty .data folder to go along with the new name

  4. Move the original PDF folder from old .data folder to this new one.

  5. Done. When I did this my entire library was recovered and the links to the pdf’s were all working.

Good Luck

I am using Word 2007, saving my files on Dropbox (version 2.4.11) , and saving my EndNote (Version X 7.0.2) library on Dropbox.

I repeatedly get the error message mentioned in this post:

_ Database error. Please verify that no other user has this library open simultaneously with write access. _

_ If this error persists… use Recover Library on the Tools menu. _

_   _

I have used the Recove Library option on the Tool menu successfully. Then the new library with the word “saved” appended to the file name works fine-  until I shut down EndNote and the Word file - next time I try to re-open the EndNote library, I get the same error. Pecularily, I don’t get the error message EVERYTIME I try to open the library, but there doesn’t seem to be a reason as to why sometimes I have to recover the library and sometimes I don’t. Because the problem reoccurs, I end up with a library called “xxx-saved-saved-saved”. Not a show stopper (ie it still works) but very strange.

I tried to pause sychronising on Dropbox, it does not seem to have had an effect.

Can anyone advise on the best solution? Is it acceptable to have an EndNote library on Dropbox?



Dropbox is not recommended.  See this knowledgebase article.

I lost two libraries already with this same message. The recovery strategy doesn’t work with my last very well organized library. Any recovery suggestion ? I am on a PC right now. I will try on my Mac tonight. I would REALLY like to recover it. 

Thanks !

using drop box?  –

If the original .DATA folder is backed up somewhere, you should be able to recover it – by creating an empty text only file with the same name as the .DATA folder, ending in .enl (so for library.DATA, a file called library.enl)residing in the same folder as the the .DATA folder (not in the .DATA folder).  But if that .DATA folder was overwritten – it is toast.  

So move it out of the drop box and see if you can recover it.  Everything you need (groups, PDFs etc) are in the .DATA folder.  The .enl file is really just a pointer.  


I just upgraded to Endnote 8 and deleted the EndNote 7 application from my computer. Downloading references from the library isn’t as smooth as it used to be. I only have endnote on my personal laptop. Now sometimes I get this EndNote error message that says “This library is currently being used by someone else. Try opening it again later.” 

I’m the only one using my library. Whats up!?!

I was using cite while you write in Endnote 8 on my mac and had to edit a citation. I saved it and I got an error message and had to force log off the computer. Upon restarting, I can no longer access my endnote library and receive the error message “The libary is currently being used by someone else. Try opening it later.”

What is going on?

Can anyone help?

I am trying to download a reference from google scholar however sometimes when I drag the reference from the download menue into endnote, the following message pops up: 

"This library is currently being used by someone else.  Try opening it again late"

I often restard my computer and it usaully works, after a few goes!


Hi,  it happened to me. but I can recover my endnote file.  it is very important to me. 

please please help me.



thanks this worked a treat