Google Scholar Journal Field Error

I am running Endnote X9 and attempting to import citations from Google Scholar (using Firefox).  When I open the citation file in Endnote, the Journal name is listed at the end of the author field (after %j) instead of the journal field.  I’ve tried a few different import filters but, nothing fixed this.  Is there a google scholar import filter that I’m not seeing?  I have Endnote selected in my Google Scholar settings.

Has anyone else had this issue?


You can replace the current EndNote Import filter with the one from our website.

Double-click on the downloaded file to open it.

Click the File menu in EndNote and select Save As.

Be sure to save it with same name then Click Save then Close the window.

You can now delete the file that was downloaded a copy has been added to EndNote.

You can now try to import references into the library again.