Problem with APA output style

I think I have a problem with my EndNote X2, but I do not know how to fix it. So, I decided to ask experts in this forum.

Whenever I use EBSCO’s “Export to Citation Manager,” this fine feature always imports the first name as the last name.

For example,

In EBSCO ==> Penny McKay. RESEARCH INTO THE ASSESSMENT OF SCHOOL-AGE LANGUAGE LEARNERS. Annual Review of Applied Linguistics, Volume 25, Number 1 (January 2005), pp. 243-263.

In EndNote X2 ==> Penny, M. (2005). RESEARCH INTO THE ASSESSMENT OF SCHOOL-AGE LANGUAGE LEARNERS. Annual Review of Applied Linguistics, 25(1), 243-263.

If you look closely, you will find out the last name “McKay” is abbreviated instead of the first name, which is not correct according to APA

style. In addition, there shouldn’t be a comma after “Penny” because Penny is not the last name but the first name.

I tried newly updated styles, but they didn’t help me. I am sure there is a way to control it, but I can’t find where. Would you please,

help me? Thanks much for your kind help in advance.

I can’t replicate this problem with Ebsco’s Business Source Premier database, but it might occur with other Ebsco databases.

Alternatively it might be a problem with the filter which is importing the records when they are directly exported from Ebsco.

In EndNote, click on Edit>Import Filters>Open Filter Manager.

When the list of filters is displayed, browse to the filter called RefMan RIS, select it and click on the Edit button.

When the edit window opens, click on Author Parsing in the left-hand column.

Now look at the Name Order settings. Is the chosen option “Last Always Precedes First”? If not, change it and close the edit window and save the changes.

If you already have the setting “Last Always Precedes First”, it’s possible that changing it to “First Always Precedes Last” would solve your problem with that particular database. But it would probably create problems with direct export from other databases.

Thank you much, John!

But my problem persists even after I tweak around according to your suggestions.

But thanks for your attention to this matter.^^

Try removing any other filters apart from the edited RIS filter. (just drag them to a different folder)

Leanne! (as well as John!)

Thank you so much! Thanks to your insights, my problem has now gone!

I removed all other filters as Leanne had suggested, and I tweaked RefMan RIS as John had suggested.

And now it imports EBSCO in a way as it should be. Thanks much to both of you!

Here’s what I’ve done in addition to removing filters.

Name Order ==> Last Always Preceedes First

Interprete First Name As ==> Initial Only

Between Authors ==> Import As-Is

Last & First name ==> smart

Parenthetical Data ==> Discard

Additionally, the default author list format in EndNote X5 is wrong.  Specifically, EndNoteX5 defaults to including a comma between all authors in the creation of a bibliography.  When there are only two authors the amperstand and comma are not inlcuded, for example:

Last_Name, F. and Last_Name, F. (year). Title. etc…


Last_Name, F., & Last_Name, F.


Last_Name, F., and Last_Name, F.

I can fully appreciate the difficulty programming citation and referencing systems compliant with APA 6th, but this is absolutely ridiculous and inexcusable if you are charging your customers for your software.  

If I look here:  It seems the examples are shown with the comma & format? 

added in edit… I guess it is the extra comma when only two authors are there.  and it would make sense to me (although the two author example in th above, still has , &). 

they should edit the template author settings so that 1 to 2 just has the & and 3-100 retains the , &?  Like in the attached. None of them use the “and” instead of the “&” in their examples though. 

APA 6th.ens (60.7 KB)