Problem with downloaded output style

I am using EndNote X3 (Build 5276) and a MacBook Pro with OS X 10.6.4.  When I download an output style (specifically the ICES Journal of Marine Science) from the EndNote site my computer does not recognise it as an EndNote file  (.ens ?).  When I save it in the EndNote Styles folder and rename it with the extension .ens it still displays differently to the other style files and also does not appear to work as an output style.  When I select it as the output style in Styles Manager I get a message saying that no bibliographic style is initialised.

Any help would be greatly appreciated - I am probably missing something totally basic here. 

Just an observation - I downloaded the ICES Journal of Marine Science output style and note the file is correctly configured with an .ens extension and works fine with EndNote X4. 

Am unclear what you mean by “my computer does not recognise it as an EndNote file” since the file appears to be correctly formatted.  After downloading the output style, did you immediately place in in the Styles folder?  And when you select it via the Styles Manager, besides ticking the selection, is it also hightlighted? 

Perhaps there was a problem when downloading and renaming the style.  Have you tried repeating the process to see if the problem persists?

Cheers Crazy Gecko,

instead of just downloading the file normally (where it shows up in my Downloads folder as “unknown” with no file extension, and I did that repeatedly) I clicked “download file as” and downloaded it directly into the Styles folder.  It worked.  So simple, thanks.