Author (Year 1, Year 2) - How to format?

Dear community,

I have two sources by the same author but published in different years, and I would like to cite them both in-text, like:

“[…] the framework originally developed by Author (Year 1, Year 2), […]”

I know how to format Author (Year), but for some reason it does not work with two years.

Can somebody please help me?

Thanks a lot in advance!

So, you would like the citations to appear like “Smith (2009, 2012” within the text? If so, you will have to configure both citations into the group to “Display as Author (Year).” Click on the group of citations and then click Edit & Manage Citations. For each of the citations in the group, choose the option “Display as Author (Year).” 


Jason, this really doesn’t work with Author (Year).   It is only available for one citation, the options are greyed out otherwise.

The easiest way to achieve this, is to insert the group of citations normally, hide the Author, (maybe only for the one that is listed first, possibly for both), and type the author where you want it.  

Editing.  Okay – even that no longer works.  You don’t appear to be able to apply the omit author anymore on individual citations when in a group.  – All those options are greyed out.  

You can do it manually though.  Convert the citations to unformatted citations (temporary citations in some software versions).  remove the authors – moving one to infront of the curley bracket and it should work if the template is formatted correctly.  I think it should look like this in the output style (Author|, Year|)

so unformatted in the text 

Abdou {, 1999 #4416;, 2002 #183}  formats to this 

Abdou (1999; 2002)  

but the Author name is not automatically generated by Endnote.  

Mea Culpa Jason.   

YOU CAN do what Jason says, but have to go into the More, and select each ref and apply the Author (Year) to each of the citations in the group.  

This only works for single authors or where all the authors are exactly the same – so Author et al where first author is same but other authors are not, it doesn’t work (this has always been an annoyance and means you do need to resort the the work-arounds I described).  

Thanks to you both! :slight_smile: It worked as you described it.

My apologies if my screen capture was not more specific. If you click on the Citation and then go to Edit & Manage Citations, that will take you to the same dialog as right-clicking or control-clicking (for Mac) on the citation and selecting Edit Citation(s) > More.

Jason, the fault was all mine!