Customize groups side bar

Thank you for reading my requests.  It would be great if the groups sidebar in Endnote could be further customized.  Here are some of the customizations I would find very useful.

1.  The ability to remove (and add back) certain mandatory groups that are currently displayed automatically by Endnote.  For instance, I don’t use the “EndNote Web” and “Find Full Text” groups.  I also rarely ever use the “Trash” group.  Removing these groups would make the sidebar less cluttered for me, and in the case of the Trash group, it would allow me to move my other groups/group sets somewhat higher, so fewer of them would run off the bottom of the screen. I could then display the Trash group temporarily if I unexpectedly needed to retrieve a reference I had discarded, and then turn it back off after retrieving the reference to save screen space.

2.  I would like to be able to adjust the amount of space that exists between group sets.  I don’t find the additional space between sets visually necessary, because the groups within each set are already indented, so its easy for me to differentiate where each set begins and ends. Having less space between the sets would enable me to fit more of them on the screen, so I don’t have to scroll down so much.

3.  Perhaps, it would also be helpful to set a unique font for the sidebar, although this feature seems less important to me.

I agree with the improvements on Group pane. When I try to move a group set, I click on the name of the group set, but the cursor doesn’t highlight it. I just drag it up and down, and it moves anyway, but it is a little bit weird interface.

Once again…clicking multiple groups and display references that belong to all of these groups (AND operator), or any of these groups (OR operator). That’ll be really really really…helpful.

Myoshigi, I’m not sure if the Endnote team has read this suggestion.  Do you think I should email my suggestion to them as well?

I believe they read all these suggestions, but it is better to spell out your voice if you have time.

Group function is really a key, IMHO, to make Endnote as a better database management tool. So, hopefully, they integrate these enhancement in the future versions.


It’s not so terrible bug, but it is clunky behavior. I am recently reorganizing groups and frustrated about the group pane display behavior. Maybe this is because I have so many groups (~480), and I have ~30 group sets to re-group them. But, what happens is, the expansion/collapse doesn’t show the correct outcome, and some groups are displayed kind of duplicated up and down. It looks completely screwed up. This happens relatively often (not always) when the scroll bar of the group pane is pushed down to the bottom, and when the group around the bottom is expanded. Then, I see funny duplicated expansion around the bottom of the pane. I have to scroll up and down to correct this funny display, but it’s annoying to do so every time I expand the group sets at the bottom. I’m still trying to find out what conditions make this reproducible.

To reduce this problem, I was using 8 point font to display library, but then “+” symbol before group set disappears.

GUI of the group pane needs some improvement.

Message Edited by myoshigi on 12-14-2009 09:19 AM

Myoshigi, I’m wondering if you have ever noticed either of the following. 

  1. When I import a reference into Endnote manually from the web, if I try to drag the reference to a group, the number of references listed for the group doesn’t change, because the reference wasn’t added.  However, if I drag the reference to the group a second time, the number changes.  This happens anytime I try to drag a manually imported reference to a group. 

  2. The groups side bar doesn’t scroll well for me when I use the scroll wheel on my mouse.  When I scroll, the side bar usually moves down (or up) a few millimeters and then stops. 

Message Edited by hsrstud on 12-14-2009 08:47 PM


Let me say for the #2 first, and I do see the same problem. The scroll bar doesn’t go down to the bottom, and seems stop in the middle. But that doesn’t happen all the time. It seems it is related to some groups are expanded or collapsed. It is just annoying.

Talking about #1, I’m not sure. I drag reference from “Unfiled” smart group to my custom group, and usually the number increases right away. But I don’t “import from the web”. What does that mean? Do you mean, import from EndNote Web?

I am still sticking to use local library mode, the method of importing is to export as MEDLINE text from online source (Pubmed), and import the text using “import” command and a dedicated filter. I don’t use Endnote Web, or I don’t use connection file either, just because I need one external program to parse senior author from the exported text. Anyway, because I don’t use these direct import from online, I can’t tell.

Message Edited by myoshigi on 12-14-2009 08:04 PM

Thanks myoshigi.  I also don’t have any problem dragging a reference from the Unfiled group to one of my user-defined groups.  I think I only have this problem with the Imported References group.

What I mean by import is that sometimes I’ll go to a journal database like Wiley InterScience, find an article I’m interested in reading, and download its citation from the website into Endnote.  It then shows up in a temporary group called “Imported References” similar to the Trash or Unfiled groups.  The “Imported References” group only shows when you import a reference from the web. 

Okay, now I got what you meant. I just tested if my “Imported references” group behaves in the same way or not, but the number increased right away. However, I noticed, when I “immediately” drag the reference from the “Imported references” group, then I can’t drop it off anywhere. I have to release the mouse button once, and then try it again. Then I can drag and drop it off to any custom group.

Maybe that’s what you’ve seen.

I also noticed the group set is just a collapsible/expandable devider for groups. I can’t find information of “group set membership” for each reference in the Record summary.

In any case, the group function and display needs improvement!

It’s strange.  For some reason I am able to drag the reference from the Imported References group on my Windows 7 machine (as long as I click on it once as you suggest), but I don’t think this was the case on my Windows XP machine.  I recall having to drag it to my group twice, regardless of whether I clicked on the reference. I’ll have to test this again tomorrow.

I’m not sure what you mean by the following:

“I also noticed the group set is just a collapsible/expandable devider for groups. I can’t find information of “group set membership” for each reference in the Record summary.”

Are you saying that you wish the record summary would show the group set a reference is stored in, in addition to the groups that a reference is stored in? This way you could quickly identify the group set you need to open to access the group your reference is stored in (as this is shown in the record summary).  

Yes, you got what I wanted to say. 

It’s a little off topic from this thread, but I have several “apoptosis” groups under several group sets, and if I look up the group membership from Record summary, I can’t tell which one it belongs to. So, basically, the group set is not doing anything besides hiding (collapsing) and showing (expanding) groups. That’s why I said it is just a divider.

If Endnote developer will add search feature of group membership, and add more sub-groups, this “feature” will cause problems across versions. The developer added one thing after another incrementally, and creating own problems. They should have this feature with unlimited subfolder structure (like Windows explorer), and unlimited group numbers.

Agreed.  Well, hopefully they’ll address some of these issue in their next release.  I’ll report back tomorrow on whether clicking on a reference before dragging it to a group works on my XP machine.

I tried clicking on the reference first before dragging it to a group on my Windows XP machine and this appears to work.  I was really surprised, since I thought I tried this before.  I guess this problem is solved.  Thanks for your help myoshigi!