EN6 new issue with find Dupes

I am trying to remove duplicate records from the library but each time I run the Find Duplicates it does find some 20 or so, but then after each selection is made to keep a given record the discard one is not deleted.

I have then just searched for Author names & titles and seen the duplicates in my main library DB and tried to delete (move to trash) the records I do not wish to keep.

EN6 will not allow me to delete these in this DB only.

It was working fine until recently.

I decided to try a "recover Library function in the event that there was some indexing issue or corruption.
The Recovery begins then in moments a message pops up 0 records were recovered.


If you send your library to Technical Support someone can take a look at your library and find a way to repair it. Sometimes it is necessary to recover the library using a different version of EndNote or EndNote on a different platform. Sometimes EndNote for Macintosh can recover a library that EndNote for Windows cannot recover, and sometimes EndNote for Windows can recover a library that cannot be recovered by the Macintosh version.

The best way to send your library is in compressed library format. When you have the library open in EndNote click on File > Compressed Library. Select create, with file attachments and all references. This will create an ENLX file that will include both the ENL file and the DATA folder. If the size of the ENLX file is too large for regular email do not be alarmed. We have a file transfer service that can be used for transferring large files.

I continued to try to resolve the issue.
It seems that by closing EN6 library then the program and restarting EN6 (program) then reloading the library it seems to fix it except for a single record that shows up twice.  I copied that single record to a new library and it also displays as a “double record.”

The program would not allow deleting the “second” one displayed that is exactly the same and would show up as a dupe.

The Find Duplicates in EN6 is not working well as when you select the record to keep it does not delete the other and only by choosing SKIP and manually removing the unwanted records would it work.

The issue may be related to linking PDF files.

Now all is fine and once I deleted the PDF attached file from the record I could delete it.

So the attached file index was corrupted?