Endnote X1 "Unspecified Error" when Word 2007 comments open Reviewer Pane

Anybody had this problem – when using Word 2007 in Windows XP, and adding comments that get lengthy enough to open the Reviewing Pane to accommodate the long comments, an Endnote X1 “Unspecified error” message pops up with an OK button.  Clicking the OK button makes the message go away, but if the Reviewing Pane stays open, the error message comes back, again and again, as long as the Reviewing Pane remains open.  After closing the Reviewing Pane, the Endnote X1 “Unspecified error” message does not re-appear.

What’s causing the “Unspecified error” message and how can I get it to stop (because I’m putting lots of comments into this document!!!)


Yep, I’ve got the same exact problem.  Seems to happen even if EndNote is not running (suggesting, perhaps a problem in the Word 2007 EndNote macros…?).

Anyway, what I did was simply go to the Office Buttion/Word Options/Add Ins/Manage COM Add Ins and disabled (by unchecking)  the ‘Cite While You Write’ add-in.  This fixed the problem so that I could address the comments. Then I can turn the Review pane off and the ‘Cite While You Write’ add-in back on to deal with references.

It’s definately a bug, and an unacceptable one as well.  Giving the generic ‘Unspecified Error’ is either sloppy coding or they have a catch-all error handle and EndNote is doing somethign that the programmers aren’t aware of.

Hopefully it will be fixed in a future release; it’s quite annoying.


Message Edited by pfredrick on 06-11-2008 09:34 PM

Message Edited by pfredrick on 06-11-2008 09:35 PM

Same problem here, using Word 2007 and Endnote X2.

I have the same problem. Running Endnote X1.0.1 Vista 32 and Word 2007.

Another problem: With the CWYW add-in enable within Word, screentips on comments and other review items disappears immediately. Disable the add-in, screentips become visible again.

Following drstan:

The second problem (comments flash in a tooltip then disappear) occurs with Endnote X2.

I hadn’t related this to the macro, but you are right, I only suffer from it since I installed EN

I have the same problem with Word 2007. Hope it will be correct with the next patch.

I’m guessing this problem hasn’t been fixed yet, but I might have found a workaround.  It seems this problem is caused by the travelling library in the word file.  I’ve been able to silence the error message by clicking the Endnote menu in Word and then re-exporting the traveling library to an Endnote file.  In my case, I just export to the same Endnote file every time I open my paper either with or w/out Endnote actually running.  This seems to shut it up, at least until the next time the document is opened.

Here we are almost a year later and EndNote still puts bugs into Word 2007 even when you’re not using EndNote.

This software maybe the “industry standard” but it still sucks. I don’t know how this company gets away with such terrible software.

My experience is, XP is better than Vista, Word 2003 is better than 2007, and Endnote X2 is better than X1.

Well, not everybody can control these version compatibility issues, so I understand your frustration. 

Track Changes comments and EndNote formatting just don’t play well together – they both use field codes that are very similar to each other, and consequently EndNote gets confused when it sees a comment, attempts to format it, and we get problems.


We don’t currently have a solution to this issue, but we do have a workaround:  Basically, you want to make sure that you don’t have both comments and formatted citations in your document at the same time.  If you must use comments in your document, unformat your citations (using the Unformat Citations / Convert to Unformatted Citations command), then turn off Instant Formatting (see instructions, below) and use only unformatted citations in your document.  Then, when you’re ready to format your bibliography, delete all the comments in your document using the “Delete All Comments In Document” command on your Reviewing tab, then use Format Bibliography or Update Citations and Bibliography (depending on the version of Word that you’re using). 


To disable instant formatting:


  1. In Word 2002 (XP)/2003, select Tools / EndNote / Format Bibliography.

    In Word 2007, go to the “Add-ins” tab and EndNote / Format Bibliography.

    With EndNote X1/X2 and Word 2007, hit (ALT+3) on your keyboard to bring up the Format Bibliography screen.
  2. Select the “Instant Formatting” tab.
  3. Click the Turn Off button.

This will prevent issue when working with the current document. To prevent it from occurring in future documents...

  1. In Word 2002 (XP)/2003, select Tools / EndNote / Cite While You Write Preferences.

    In Word 2007, go to the "Add-ins" tab and EndNote / Cite While You Write Preferences.
  2. Uncheck the box labeled "Enable Instant Formatting on new Word documents".

I’ve been using the method I described above in post 7 & it has worked very well for me (word 2007), even for documents with all types of revisions & comments.  And it doesn’t require deleting comments or unformatting citations.  But then again I’m working w/ papers for which I have the Endnote library files.  I think it would work if I didn’t, however.

For many Word 2007 users, keeping comments and formatted citations out of the same document is not a feasible work-around for the ‘unspecified error’ problem–we need to keep comments/changes showing and also have citations formatted. One work-around that is helpful is to disable EndNote while working in ‘track changes’ mode --ie, while entering comments and changes – because the ‘unspecified error’ message tends to open when comments are being entered in ‘track changes’ mode. Enable EndNote only when it is time to work on citations/bibliography. This is fast and easy: Click the Office button. Choose Word Options > Add-ins > Manage > Word Add-ins > Go. Uncheck the checked EndNote items: (EN10cwyw.dot and EN10cwyw.WordXP.wll on my computer) > OK. After editing in ‘track changes’ is complete, turn off ‘track changes’ and then enable EndNote. To enable EndNote again, follow the same steps as above, but check the boxes that you unchecked previously.

1 Like

jbedol’s workaround is much better than that suggested by the moderator: I often write papers, with endnote, refs, comments, and track changes, while working with a colleague. Disabling the EN macros is reasonable in this context, making do without any of the above disrupts the natural workflow of collaboration. I should imagine that I am not the only academic with this work pattern.

What I would like the software programmers to do is to prepare a simple macro that will toggle between activate and disactivate the range of EN macros. Should be a simple work for them, and helpful for users. Me; I cannot tell a macro from a hole in the ground. And then add this macro as a clickable item on the endnote ribbon section.