Endnote X6 problem with Office 2013 Preview x64

Endnote X4 works perfectly with the 32 bit Word 2013 as part of the Office 2013 preview; however Endnote X6 does not appear in Word menus, does the program itself recognize the presence of Word on a system with x64 Office 2013 (and no other version of Office on the system).

Different machines but both running Windows 7 x64 SP1 with all updates.


Mike Martin

We have not done any testing of EndNote with Microsoft Office 2013 64-bit Preview, but if you do not have any other versions of Office on your computer you can try the following steps.

Close Word and open the Computer. Go to C:\Program File (X86)\EndNote X6\Product-Support\CWYW\x64. Select “EndNote Cwyw.dll” and “ManagedCode.dll.” Right click on the selected files and click on Copy.

Go to C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16. Paste the two files into this folder to replace the copies that are currently there. You should also see files called “EndNote Cwyw.dotm” and “EndNote Web Cwyw.dotm.”

Once the files are in place click on File > Options > Add-ins. On the right side of the in the bottom let arrow you will see Manage: COM Add-ins. Click on Go.

In the COM Add-ins window click on “add” and go to C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16. Select EndNote Cwyw.dll and click on OK.

When the file appears in the COM Add-ins window make sure it is checked and then click on OK. Restart word and check to see if you have an EndNote X6 tab.

Thanks for the instructions - quite understand that you haven’t done any testing yet.

I followed the instructions, copied over the two dlls and then opened Word to import the add-in. It turns up in the selection menu, but when selected it is not listed in the add-ins available to be enabled or disabled. I played around and changed some of the trust center settings - making the Common Files/ResearchSoft directory and sub-directories one of the trusted locations - but that had no effect either.

Word is recognizing it as an add-in dll, since if one selects another file, one gets the error message, “not a Com Add-in”, and there is no error message with EndNote Cwyw.dll just the failure to list it.

This isn’t the only add-in that fails in Word 2013 - it loads Adobe PDFMaker without that making available the PDF menu.

It is possible that the Word 2013 Preview 64-bit edition does not work with EndNote X6. I use the 32-bit version on my computer at home.

I have another Windows 7, 64-bit partition on my home computer that has no versions of Word installed. I will try to install Office 2013 64-bit and see what happens.

By the way, when you go to C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16, what other files do you see in this folder?

Interested to hear how you get on.

The other files in the folder are just the templates for Endnote and Endnote web:

EndNote CWYW.dot

EndNote CWYW.dotm

EndNote Web CWYW.dot

EndNote Web CWYW.dotm



I just tried what you desribed and it doesn’t work at all. I copied the two files as described. When I click “Add…” in Word’s COM Add-Ins dialog and then select the Endnote Cwyw.dll I get an error message saying

‘C:\Program Files (x86)\Common Files\ResearchSoft\Cwyw\16\EndNote Cwyw.cll’ is not a valid Office Add-in.

This is on a US Win8 (RTM) system with Office 2013 preview version 15.0.4128.1025 x64.

If you have a beta version that might work and you are interested in someone trying that out, please feel free to get in touch with me (actually, please get in touch with me!).



It appears that EndNote X6 does not work with Word 2013 Preview 64-bit.

I installed Microsoft Office 2013 64-bit Preview in a Windows 7 Home Premium 64-bit computer. After I installed Office 2013 I installed EndNote X6.

When I opened Word and so no EndNote X6 tab, I closed Word and copied “EndNote CWYW.dll” and “ManagedCode.dll”
 from C:\Program Files (X86)\Product-Support\CWYW\x64 and pasted them into C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16 to replace the copies of the two files that were currently in the folder.

When I reopened Word and tried to register the COM add-in from within Word I received a message that the DLL file was not a valid Office add-in.

Any plans to fix this?

The developers have advised that because of the version of the Visual C++ run time components used by Microsoft Office 2013, EndNote is not able to register the DLL file. However they provided a workaround.

First go to http://www.microsoft.com/en-us/download/details.aspx?id=26368

Download and install vcredist_x64.exe.

Repair or uninstall EndNote.

Open a command prompt window as administrator. On Windows XP click on Start > All Programs > Accessories. Right click on the Command prompt icon and click on Run as. Put in the Administrator password.

On Windows Vista or Windows 7 click on Start and in the “search” box type cmd. Right click on cmd.exe and choose Run as Administrator.

In the command prompt window type regsvr32.exe “C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16\EndNote Cwyw.dll” and press ENTER.

When you receive the message that the registration succeeded you can type “exit” to close the command prompt window and start Word. You should now see the EndNote X6 tab.

This should also work with EndNote X4.0.2 and EndNote X5.

Because Word 2013 is only a preview release and not the final release, there will not be any patches or updates to make EndNote load normally in Word 2013 Preview. Once the final release comes out there will be testing to determine what needs to be done.

Just to say that I have applied this solution and it worked fine on EndNote X6 - however I did manually copy over the x64 versions of the dlls before doing this (since a repair installation will replace the x86 versions).

Great, it is now working! Thanks for the workaround.


now that Ofice 2013 RTM has been available for a week, is there any timeframe when a patch will be available? Must I try the workaround or can I wait for the patch? Thank you!



I tried to perform the suggested operations, however, in the Com add-ins, upon file selection it does not give any error (after replacing the .dll files) however it doesn’t show up in the available add-ins.

I am running Office 2013 x64 (the release version) under Windows 8 x64.

I wonder if anyone succeeded integrated Endnote X6 or other version in Office 2013 x64?

Thank you for the support

Did you try the procedure listed in post 9 concerning registering the dll using regserv32.exe?

It certainly works for me in Office 2013 x64 in Windows 8 Pro x64.

Also I used the 64 bit version of the dlls, location indicated in the first post, rather than the 32 bit versions which post 9 seems to recommend registering.

Thank you for your reply,

I did try to register, but it never worked.

I already solved the problem. I was not including the " " between the .dll file adress in regserv32.exe.

Thank you



Endnote x6 works with Word x64 RTM (Win 8).

After you copy 64-bit *dlls as described, please rerun

regsvr32.exe"C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16\EndNote Cwyw.dll" again.

Menu will appear under Word after restart.

when i try to run the regedt i get:

was loaded but the call to DllRegisterServer failed with error code 0x80070005

please advise how to fix this?

If you try to register a DLL by using Regsrv32 while you are logged on using an account that does not have administrative credentials, you may receive this message. As a workaround, you can run the Command Line with Administrative rights. For Windows Vista and later users:

  1. Exit the command line if it is already open.

  2. Click the Start Button, then in the Search box type cmd.

  3. In the list above, under “Programs” right-click on cmd.exe that appears above and choose “Run as Administrator” and click “Continue”.

  4. In command line window, follow the steps to register the dll file again.

Jason Berman
Technical Sup Rep RS

Thomson Reuters

Phone: +1 800-336-4474

Using Windows 8 Pro x64 and Word 2013 x64, Endnote X6. I did a repair install of Endnote, copied the x64 plugins over and registered the dll successfully as instructed, however the menu still does not appear in Word, though it is listed and enabled in ‘Add-Ins’. Anything else that can be done?

Thank Henrry, It’s really useful

I have tried with Endnote X5, Word (office professional Plus 2013), Win 7 Ultimate (32-bit). I’ve changed the command you guided us (regsvr32.exe “C:\Program Files (X86)\Common Files\ResearchSoft\CWYW\16\EndNote Cwyw.dll” ) to

(regsvr32.exe “C:\Program Files \Common Files\ResearchSoft\CWYW\15\EndNote Cwyw.dll” )

The Endnote tab reappear.