Endnote X7.2 compatible with Max OS X Yosemite?

I want to upgrade my Max OS X to the lateste release (Yosemite). However, I’m not sure if Endnote X7.2 is compatible with the new OS.
Can you provide feedback on this issue?

Hello afonsopatrao,

We are actively testing EndNote X7.2 against the Golden Master version of Yosemite. However, we cannot claim official compatibility until the release of the final version. See Gillian’s response about this EndNote practice from last year’s Maverick’s release: 


Seeing that the Yosemite release is to happen shortly, I will keep everyone updated here, as well as on https://www.facebook.com/EndNote


and of course, in our new community in EndNote online.

Thanks for writing,

Meredith M.
EndNote Team

We’ve completed our preliminary testing and found that X7.2 works well with Yosemite! Let us know your experience. 

Thank you,

Meredith M. 

The EndNote Team

Works prettty well. PDFs showing much quicker and better on my library. The Groups panel is not working properly though you can click around a bit and still get ‘All References’ to show after a search. The related drop down menus don’t work right either; that is “Show All References”, the menu ‘lights up’ but nothing happens with <Command Shift M>.  Since I use EndNote all day long this matters to me. It is working well though I would say, hope a patch fixes the Group Panel.

I keep saying that we users need more strategic discussion on this software, software itself is not going to solve all the issues. For example is it really a good idea to put a whole thesis on a single Word doc? Should we bother with Pages at all? etc. etc. I appreciate a lot of us have cost issues too.  

Nearly all my reading and pdf’s will be on my EndNote soon. Maybe Mac Power Users or some other reputable podcast could cover these topics some time, I will suggest it to them? I did feel a bit strongarmed into Yosemite actually; I think I will resist the next OS with more vigor! :slight_smile:

I am running X7.2 with yosemite.  The application is very slow when searching, scrolling, opening PDFs.  Has anyone had the same experience?  Any suggestions?  I did not have this problem prior to upgrading to Yosemite.

i also have a problem using endnote x7.2 in yosemite 10.10 final release

i can’t open any file, nor create a new document, endnote x7.2 will crash

please update a.s.a.p. 


Hi I also recently upgraded to Mac OS X Yosemite, and thereafter my endnote 7.0 was unable to work. Everytime I tried to update my bibliography in word, endnote will just quit unexpectedly and there is an error message saying "Endnote is not responding. Error = -609. 

Could someone please advise/help?

Thanks very much.

I also just recently updated to Yosemite, and now my Endnote will not work. It will open, but the first time I try to click on or open a reference, it crashes. It also will not sync or update. Any advice on how to fix this problem is greatly appreciated.

Hello everyone,

As we were testing X7 on Yosemite, we weren’t able to replicate these issues. My thinking is that either you’ve unearthed issues we weren’t able to, or that these issues are related to something else. Either way, I would recommend that those of you experiencing problems (like the Cite While You Write issue, or the inability to edit a reference) to please contact our Support Team here: http://endnote.com/support

As always, thank you for your feedback,

Meredith M.

EndNote Team

I am experiencing the same problem, although my computer crashes fairly often these days. Very annoying! I have been looking for updates that can fix this issue. No luck so far. Hopefully the EndNote team will fix this very soon. 

Just couple of hours — before i updated to the new version of Yosemite — Endnote X7 worked fine. However, as you, after updated to the Yosemite 10.10.1 — whenever I tried to open the Endnote X7, soon it became no responding. If I try to use in word, then error message : endnote is not responding , error code = -609.

Please update Endnote X7.2.1 soon, so we can use it!!!

Have been using EndNote X7.2.1 successfully with Yosemite - stopped working today, error: EndNote is not responding. Error = -609. Please advise.

Having the same issue. I can’t even uninstall endnote because my macbook crashes whenever I open the app!