EndNote x7 damaged library - unable to repair

Dear All,

Can anyone suggest how to repair a damaged library if the standard approaches don’t work? I have been using EndNote X6 for many years now and have never come across this problem before. I have a large library (~2400 references) stored on a shared drive, which I access from a standard user profile at work and have recently started using over a VPN connection from home. I have also just upgraded to EndNote X7. Since yesterday the library will not open, and gives the error message:

Database error. Please verify that no other user has this library open simultaneously with write access.

If this error persists after restarting EndNote, then the library may be damaged. To repair it, please use the Recover Library command on the Tools menu.

The standard and advanced recovery methods outlined elsewhere on the forum didn’t work (sorry, can’t post a URL for some reason…). The recovery just finishes saying it has retrieved 0 references…

I have tried this unsuccessfully with both EndNote X6 and X7 (both of which are able to open other libraries without problems), so I think it is either that the library is irreparably damaged, or that the VPN connection has somehow failed to close its access to the library. The icon for the library is now suggesting that it’s an Adobe Acrobat document, despite still having the .enl extension… Any suggestions?

Many thanks!


Have you tried copying the filename.DATA folder to a new place and then creating a filename.enl file with a text only editor that is empty in the same folder as the copied .DATA folder and see if that will open it?  

Thanks for your message. I have tried this, but unfortuately it doesn’t work. The repair runs, but finishes saying 0 references have been transferred, and the new .enl file still won’t open. I’ve sent the damaged library to the Thompson technical support, but if anyone has any other ideas I’d be delighted to hear them.



Let us know how it goes.  I am concerned that it has been overwritten during one of the attempts at repair.  Do you have a recent backup?  

The recovery appears to have been a success! It seems the problem was having the library on a shared drive, and accessing it from multiple PCs. I’ve got the recovered file on a local drive now, and will be using the sync function in future. Thanks for you messages.



I’ve done the same mistake as you did, KOKluser - files saved on a shared drive and now having the same damage message.

Can you please tell me the email adress that you use to ask reparation?

Thank you in advance.

Hi reginalencastre,

I used the live chat option to speak with a tech support guy, who was able to solve my problem very quickly (~24hours). I had to upload my library onto a fileshare service though, as it was too big to e-mail. I’d recommend doing this this way as I could explain everything in detial and respond to follow up questions straight away, the only problem is that I now can’t find a link for live chat on the Thomson Reuters website… You might have to settle for logging a technical support request instead.

Best of luck!

I have a same problem. I have a damage library and after try to recover it, The recovery just finishes saying it has retrieved 0 references…

I have copied the filename.DATA folder to a new place and then Rename the corrupt .enl file to anything else in the same folder that I have copied the filename.DATA folder .

I open it in the Endnote and it works.

but the problem is that previously I have organized references into sevarl group sets and sub-group, but now I could not see them. 

is there any way to solve this issue?

please let me know