Endnote X7 EXTREMELY Slow on Rather Fast Hardware (OS X)


my Endnote X7 7.0.1 (b 9257) is really, really high-latency with everything that I do with it. Examples:

  • When I edit a reference in an open window and then want to save and close it, it takes 10 seconds (!) until that has happened.
  • When I click in the search field, it takes 2 seconds until the cursor actually appears.
  • When I then do a search, it takes many seconds until the result is compiled.
  • When I am in a group and want to click on “All References” to do the search, it takes something like 5 seconds until it switches over and shows the list with all entries.
  • It takes 7 seconds to open a reference with a PDF with text in it (not a scan). 9 or 10 seconds if it’s a scan. The list goes on like this.

In some rare moments, the switching between groups is normal, search is fast, everything’s cool. I don’t know when, though. It’s not about the seconds, it’s about the extreme latency that makes you go insane. In fact, often times, I don’t even search for something if I don’t REALLY need it, because it’s too much interruption and waiting while writing.

The thing is, I’m on an ok-fast laptop with an intel i7 2.6GHz processor with a large SSD mass storage and 16GB RAM, so I can’t imagine my machine is too slow. A colleague of mine has a two-year old MacBook Air, and his Endnote X5 is snappy like anything else.

What’s the matter here?



In case this is needed:

Endnote X7 7.0.1

~1300 Reference entries

~1100 of which with PDF attachments

3 word document records with 43, 71 and 77 citations

OS X 10.8.5

MacBook Pro Retina 2.6 GHz, 16 GB RAM, 768GB SSD

I have had this happen on documents from previous versions of word or endnote.  I find that if I unformat, and reformat - the lags go away.  On rare occassions I also need to clean up field codes using endnote or words tools for this.  I use Endnote tools, if there are other fields in the document like tables, captions, etc), but prefer word select all, ctrl+shift+F9 on A COPY) after converting citations to temporary (NOT plain text).   More details in the KB article here: http://endnote.com/kb/82629

1 Like


Thanks for your response! I’ve tried the solution you suggested now, and indeed Endnote appears to be back to normal. Haven’t had the opportunity to check if everything’s cool in the document yet, but I’ll post here again after I have and can say if the problem is solved.

Best regards,


Looks like it worked out so far. I’ll mark your answer as a solution and post here again if I need to revise this assessment.


1 Like

Thanks for your support. I have fixed this problem

1 Like

Thanks for sharing

Ok, I have to take it back. I’m meanwhile to the state where going through the whole process of unformatting, copying, pasting, reformatting does not do much more than fix the problem for something like less than a day, then it’s back to SLOOOOOOOWW again. Click and wait for the reaction. Extremely annoying.

If anyone knows a solution, please advise!

I do not think that reformatting old Word or other files is a solution. In my case, I have about 31.000 entries in Endnote X7 and definitely will not reformat anything. In my hands, X7 crawls, after each start (on even the fastest PC) takes about 20+ seconds in which there is a No response error message. If there will be no solution available soon, I will move to another software.

I got to solve this problem in Window 7 64-bit to EndNote 7 and 7.1**.**

Follow my tutorial and solve your problem too.

Step 1:

Delete the Word Data registry key

Most of the frequently used options in Word are stored in the Word Data registry key. A common troubleshooting step is to delete the Word Data registry key. The next time that you start Word, Word rebuilds the Word Data registry key by using the default settings.

To view these options in Word 2002 or Word 2003, click  Options  on the  Tools menu.

To view these options in Word 2007, click the Microsoft Office Button, and then click  Word Options.

Note  When you delete the Word Data registry key, Word resets several options to their default settings. One such option is the “most recently used file” list on the File  menu. Additionally, Word resets many settings that you customize in the Options  dialog box.

To delete the Word Data registry key, follow these steps:

  1. Exit all Office programs.
  2. Click  Start , click  Run , type regedit, and then click  OK.
  3. Locate the following registry subkey, as appropriate for the version of Word that you are running:
  4. Word 2002:

HKEY_CURRENT_USER\Software\Microsoft \Office\10.0\Word\Data

  1. Word 2003:

HKEY_CURRENT_USER\Software\Microsoft\ Office\11.0\Word\Data

  1. Word 2007:

HKEY_CURRENT_USER\Software\Microsoft\ Office\12.0\Word\Data

  1. Word 2013

HKEY_CURRENT_USER\Software\Microsoft\ Office\15.0\Word\Data

  1. Click  Data , and then click  Export on the  File
  2. Name the file Wddata.reg, and then save the file to the desktop.
  3. Click  Delete the folder “ Data ” on the  Edit  menu, and then click  Yes.
  4. Exit Registry Editor.
  5. Start Word.

If Word starts and works correctly, you have resolved the problem. The problem was a damaged Word Data registry key. You may have to change several settings to restore your favorite options in Word.

If the problem is not resolved, restore the original Word Data registry key. Then, see the “Delete the Word Options registry key” topic.

To restore the original Word Data registry key, follow these steps:

  1. Exit all Office programs.
  2. Double-click the  reg icon on the desktop.
  3. Click  Yes , and then click  OK.


Step 2 :

Go into Word, Options, Advanced, Display, and click " disable hardware graphics acceleration".   Solves the EndNote addin problem.

Step 3:

Open your Word software go to EndNote tab -> Make “Instant Formating is Off”

Step 4:

Open your Word software go to EndNote tab -> preferences -> General Tab-> Unmark “Scan for temporary citations every 30 secons” and Unmark “Check for citation changes”- Tutorial By : HackGen Email : hackgen10@gmail.com

Well, I am having similar problem but using MAC. Doesnt matter if WORD is open or not, Endnote runs slow to open, to insert a reference, for everything. My MAC is the fastest computer in the laboratory with 8 Giga of memory and super fast processor. This problem is taking valuable time every day I need the endote.

I have the same problem. It happens even when I’m only accessing Endnote and reading pdfs from my library. The more I interact with Endnote, the slower it gets. The only solution I have found is a temporary fix. Shutting down Endnote and restarting gets it back to expected speeds. 

It seems like there’s some cache memory that needs to be purged and that just doesn’t happen if Endnote is kept open. 

Very annoying and a waste of valuable time!

@ felipecarpes and TeresaLIglesias

It’s and old thread – but let’s start over.

Question to both of you: how many groups and group sets do you have?

I had a similar issue last year and tried all solutions discussed in this forum. None worked for me. Then I deleted ALL groups and group sets – and EN was back to normal. From their I strated to rebuild the groups and group sets and I identified that complicated smart groups substantially slow down EN - seeing all the features described before. After I deleted these complicated smart groups EN did not slow down any more

Try it - and let us know if it worked for you.


I completely agree with u. it takes forever to update the citations and always hangs in the process.the worst software I have ever used.it seems that its a simple sofware and requires new programming to make it faster and solve the bugs…bad programming

Commenting on a “solved thread” doesn’t help much as I don’t even read them.  

I have had very slow performance with both X7 and X8 on a fast PC and just ran all the 4 steps in your note but it made no difference. Endnote is still impossibly slow, even without Word open at all.

If this is unresolvable I will have to switch to another citation manager.

THANK YOU - deleting all the groups fixed the problem. It is still not exaclty the fastest software around but at least it is now useable and back to normal.

I discovered this problem disappears when I am not connected to the internet. Does anyone else observe this? What settings in Endnote reuqire it to be connected to the internet?


I discovered this problem disappears when I am not connected to the internet. Does anyone else observe this? What settings in Endnote reuqire it to be connected to the internet?


A colleague of mine deduced that back-up programs running in the background are causing the slow performances. Moving the EndNote files to a folder that is not being backed up may solve the problem.