EndNote X9 Error Reading Record


Recently purchased X9 for MacOs 10.14

Problem: Error Reading Record: PubMed Online Search 

Is there any solution for this yet?

Does this problem exists in Window 10 as well? 

Thank you

I’m using the demo of X9 on a Mac. 10.13.6

I get the same, IF I start by double clicking on the EndNote library. Starting the EndNote program from your applications folder, then use File > Open Library to open the library should fix the issue.



I got the same problems receiving blocks of 20, 40 or 60 records ending with the message “Error Reading Records”. This is annoying as I get only the recent 20 or 40 records which is not helpful when evaluating an oncology topic. I was unable to fix the problem; starting from the application and not from the file did not help. Any suggestions from the community?

I have the same problem. I had it in EN 8 and upgarded to 9 thinking that might be the issue.  I am running mojave on a macBoook and previously have had no issues with EN but this bug makes it unuseable for online searc hing of any depth.  Ifthe developeers read this thread this needs fixing (I have tried the fixes posted here) because without that it is not fit for purpose. Please let me know if anyone else has found the same.  Simony


Nope, not fixing the issue.

Have a look here, particularly the comment about changing the folder locations:


For me, this helped a bit. Once I edited the PubMed connection file (unticked the batch download option under "connection settings) it almost appeared normal. The error still appears, but nowhere near as much. e.g. a search on Pubmed would show the error after about 40 records - after the two items above I was able to retrieve more than 500.

The folder locations can always be changed back by clicking on the “endNote defaults” button.



Hi. I am as well still having the problem. I relocated the folders and unticked the batch download.


Hi, I’m having the same problem. Tried the same fixes (relocating folders, unticking batch download), still no luck. Using x9 on mac. Seems very variable, sometimes doesn’t work at all, sometimes can get 10 or 20 records. Not more than that though. 

I got the right method to solve this problem.
Follow the following steps:
Edit–Connection files–Open connection manager–Choose ‘Pubmed’–Edit–Connection settings–Delete ‘www.’–Done

If you are using dropbox make sure your library is outside the dropbox set of directories. That fixed it for me. 

Dropbox users: your library has to be saved outside of dropbox. This fixed it for me (X9 version on PC).