Help! When I insert citations, the magically change to *other* citations!

This is one of those problems that’s going to sound crazy, so let me preface it by saying I am working on my PhD dissertation; I have several Endnote libraries and several hundred entries, and I’ve been using it almost daily for months now.

Just today, all of a sudden, I would insert a citation; say, (Phillips, 1987) and before my eyes, I swear, it magically changed to (Phillips, 1970). I tried deleting the citation then re-entering it; I tried shutting everything down and taking a nap, then sneaking up on it; I tried deleting the entry in the library then re-entering it. It keeps happening, and it’s getting worse. Sometimes the whole thing will change to, say (Smulyan, 1994) – when it does so, it changes to a reference that I *do* have in my library.

A couple of times, magically, the citation has just reverted back to what it was supposed to be. But the problem keeps happening. It’s driving me insane.

Has anyone else experienced this, and if so do you know what the solution is?

Could you look up here?

I believe this is a curse of “record number” EN has employed over the years. To keep backward compatibility, EN can’t drop the method, but creating a lot of problem like this. 

Also, it is better to work with one master library, instead of many libraries of various categories, unless you are collaborating with other people. To manage various references in a single master library, EN now has a “group” function, which is still kind of developing.

sent you a private message.