How do you add citations into a table in Apple's Pages v5.2 (most current) on OSX 10.9 with Endnote X7?

I have a document that was originally created in Pages '09, and I was able to insert references into a table using Endnote X5 (Apple-Shift-E). I have since upgraded to OSX 10.9 and to the new Pages (v5.2). I have started working on the document in the new Pages, saved it in the new Pages format, and upgraded to Endnote X7. I have also installed the necessary plugin so that I can insert references.

I am able to insert citations into the body/text of the paper, but in using the new OSX, Pages, Endnote X7 combination, I can no longer insert the citations into the table using Apple-Shift-E or by drag and drop. When I drag and drop the reference, it will only show something like this : {Tonkin, 2014 #342}. A forced upate of the bibliography, by switching styles, does not work. It’s as if Endnote does not recognize anything contained within the table. 

I was fortunate to have kept Pages '09 on my laptop and so I exported a back-compatible version of my document and opened it in Pages '09, where I can again add references into the table using Endnote X7 and Pages '09.

I have also tried generating a new Pages document with the current Pages, created a table, and tried adding a citation, and it fails to work, so it doesn’t seem to be a file issue.

Does anyoneknow how to insert citations into a table in Pages v5.2, OSX 10.9, with Endnote X7? For now I’m using the Pages '09, but it would be nice if Endnote was fully compatible with the newest version of Pages. Thanks.

I have exacltly the same problem in Pages v5.2 and Endnote X7.  Did you manage to fix this problem with tables?


Suspect it is another implementation problem. This thread has a link to the “latest” KB article.   

 “Both Apple and Thomson Reuters are committed to improving the Pages and EndNote integration. Any feedback and suggestions for future improvements can be given to Apple using their form here.”