How to remove double URL in reference list


I had little to no problems with endnote. However, today I created a new electronic book reference in my library. I inserted the name of the author and everything looked fine until I checked the reference list. Lo and behold, I have the “Retrieved from URL” that appears twice for the same author.

I tried removing then re-installing the reference, then tried to enter it manually. I also checked to see if the URL was pasted twice but no avail.

Does any one know how to fix this?



Please accept our apology for the delayed response. You will need to edit the style you are using and changing a setting. In EndNote you can go to Edit > Output Styles > Open Style Manager > locate the style you are using > Click Edit > go to Field Substitutions > here you will need to uncheck the setting If the DOI field is empty, use: > go To File > Save As > (EndNote X2 and higher will not allow you to change the existing style in EndNote but will always apply the change to a copy of the style) Click Save to save the changes to a copy of the style > close the style window. You would then need to use the new style in your document. Please see the following website for how to change the style in your document. other option if you have the DOI field filled in then EndNote will not repeat the URL information twice. Let us know if you have any questions or if this does not resolve the issue.