Inconsistent Formatting?

Dear All,

I hope someone can give me some light. 

If I define (in my output style) Book - Short Form as:

Author, Title, Cited Pages.

The result is OK:  Stendahl, Paul among Jews and Gentiles, and other essays, 12.

But I actually need the short title, not the title, so when I put short title instead, like this:

Author, Short Title, Cited Pages.

The result is:  Stendahl, Paul Among Jews 12.

which is missing the comma after the short title.

I have tried many times and in many ways to fix this simple thing but with no avail. Why it fails to show the comma when the only different thing is the field Short Title instead of Title?



I just found the solution to thise weird issue:

In my reference entry for this book, the content of Short Title had a blank space at the end, like this:

"Paul among Jews "

I removed the space:  “Paul among Jews”

And then it worked, the comma in my footnote appears where it should.

So strange. I hope this will be useful to other users. Is this a bug? 


nice topic

(sorry, see I missed your response, which was also one of my possible thoughts below) 

Can you attach the actual Endnote output style you are using so we can look at the punctuation in the Book template?  Does the short title field include any trailing punctuation or spaces itself in the record?  

Author|, Short Title|, Cited Pages|.

You might try the above in the template.