Unwanted comma in repeated citations in Chicago 16th

Hi All,
I am hoping to pick your EndNote brains.
So here’s my issue:
In a repeated (but not consecutive) Journal Article citation, I have

Author, “Short Title,”| Cited Pages.

However, if I do not cite any pages because I’m just referring to the article in general, I’ll have this horrible thing:

Doe, “Title,”. :scream:

How do I tell EN X7 to add the comma only if there are cited pages? If not, I want to have:
Doe, “Title”. (Last name, “Title.”)

Any help you can provide is hugely appreciated!

Try editing the output style citation template, so it looks like this
Author, “Short Title”|, Cited Pages|.
This way the comma should only appear when there are cited pages.

Thank you, @knav, I had thought about that too, but the problem is that in Chicago 16th, commas must be inside the quotes, so if in the template I move the comma outside, as you suggested, it will always appear outside the quotes, even when there are pages cited.
Is there anyway I can keep the comma inside the quotes and make it so it appears only when there are cited pages?

Sorry I have no further ideas. I managed to get two quotes
Author, “Short Title|, " Cited Pages|." which might work once you converted to plain text and used find and replace. What you really need is a field substitution but there are very limited options here so I think you may have to go with your second choice. Good luck