intext citation - keeping same author together

Hi, I’m a reasonably adept Endnote user, but this one has me stuck.  Couldn’t find it in the forums either, but could easily have missied it.

In the Citation preferences for my Style, I have set <omit repeated authors> and separate with <,>.

Using <sort by Year, Author> my citations appear as such:

Red 1977; Black 1978, 1979; Black et al. 1980; Black 1981, 1982 ; White 1983

I want it to do this (it’s the bold text):

Red 1977; Black 1978, 1979, 1981, 1982 ; Black et al. 1980; White 1983

I’ve checked that Black’s initials are the same for all the references.  How do I force it to keep an author together to override the sorting by Year.  I can fix it by breaking the string of citations apart but wondered if I’m missing something obvious here?  Hope I’ve explained it clearly…

Thanks in advance

No, unfortunately there is no option to selectively override the sort order for a specific citation within the group.

As a workaround why don’t you just edit the citation to hide the entries  then manually enter the citations in the  desired order? 

Thanks Gecko,

I hadn’t thought about that - bit clunky, but in the absence of a sort, then it’ll fix it.