Journal field and alternate journal switched when importing pdfs

I’ve had this problem with X6 (using X6.0.1), and I don’t think it existed with earlier versions.  When I import pdfs (downloaded earlier), the field for journal name is populated with the alternate (abbreviated) name, and the alternate name is populated with the full journal name.  This seems like an import filter issue, but I don’t know how or where to look to try to fix this.  Any suggestions?



Really doesn’t matter if you properly use the Journal Terms list (and turn off the auto update terms features.)

I’m not sure what you mean by “properly use journal term list.”  Could you explain or point me to where to learn more?


Hello Kevin,

You can find the following information about Term List on our website.

EndNote provides a number of terms list to make sure that the journal names in your bibliography are either the full name or abbreviation as your style requires. To set up your terms list, first make a backup of your library.


Then, please follow the steps below. The procedure is also shown in an embedded video following the steps. 

In EndNote, go to “Tools > Open Term Lists > Journal Terms List”.
2. Highlight the first journal, and press [Ctrl]+A on the keyboard to highlight all the terms (on a Macintosh, this would be [Command]+A). Note: If the Journal Terms List is empty, skip to step 4.
3. Next, press the “Delete Term” button to the right to empty the list of old terms.
4. Go to the “Lists” tab at the top, and click on the “Import List” button.
5. Browse to the Term Lists folder within the EndNote folder, and choose to open the Medical text file (assuming you want to use the Index Medicus abbreviations).

If you are on a Windows machine, this folder should default to:
C:\Program Files\EndNote (EndNote Version Number)\Term Lists

If you are on a 64-bit Windows machine, this folder should default to:
C:\Program Files (X86)\EndNote (EndNote Version Number)\Term Lists

If you are on a Mac, this folder should default to:
Hard Drive: Applications: EndNote (EndNote Version Number): Terms
6. This will import the correct abbreviations into your library’s term list.
7. Next, to make sure the style is using the correct substitution, go to “Edit > Output Styles > Open Style Manager”.
8. In the list of styles, highlight the style you are using and click the “Edit” button.
9. Click on “Journal Names” on the left.
10. Make sure the style is using the Full Name or one of the Abbreviations as needed. 

Hi Tony,

Thanks for the detailed instructions.  I deleted the journal term list and imported the Zoological Sciences term list.  One journal that I had noticed not getting tagged properly was Molecular Ecology, and the abbreviation looks correct on the term list.  I imported a pdf from Molecular Ecology, and the journal fields were still swapped.  The journal field is “Mol Ecol” and the alternate journal is “Molecular ecology”.  Any ideas on what to try next?



The terms list comes into play when the paper is formated and the output style dictates a “column” for use (full title, Abbr 1, abbr 2, etc).  It won’t affect the way the fields are pulled into the record.  

I didn’t check the instructions, but you also want to make sure that you aren’t auto updating your terms lists from imported records, or it will probably incorporate a new backwards entry in the table.  That is a preferences setting.

The problem I am having isn’t with formatting references for papers, but in the basic reference information.  The field “Journal” is getting populated with the alternate journal name, and the field “Alternate journal” is populated with the full journal name.  I’ve attached a screenshot to show what I am talking about.

I did select not to auto-update the term list, but it doesn’t seem to make a difference.


Yes, I get that.  I am just a user too, and that doesn’t bother me at all.  I have tons of records which don’t have the full journal there, from year and years of strange imports.  I am just saying it doesn’t matter, as Endnote can “fix it” when the time comes to use the information.  

If you want it “fixed” then you probably need to put this topic into Suggestions.  It is inherent in the program and I don’t think that there is a filter or connection file that we have access to, that can be changed.  

I haven’t had any luck with Endnote “fixing” the journal title when formatting references, but maybe it will start working.  It does seem like it would be an easy fix for Endnote to switch fields, but I guess it isn’t a priority.  Maybe I’ll post in the feature request area.

This is also going to be limited by the information provided to EndNote. If the online database is tagging some information as the Full Journal and some information as the Alternate Journal, EndNote will parse this data as provided. In these cases, the data would need to be cleaned up by the database information provider.

I had the same problem for the pubmed import. I found the solution to that by editing the Connection filter. There the tag for Journal title (JT) was assigned to the alternate journal title and the other way around (TA was set on Journal).

To change those tags, go in endnote to Edit > conncection filters > open connection manager > choose the filter you want to edit (in my case pubmed). Choose to edit this and in the window that opens go to templates and there you can re-assign the tags to the field that you want. (see picture for the JT that I already changed to Journal; do not know why there are two types of JT tags…).

I hope that you can follow what I meant (I am not so good at describing actions on a computer)

Had a similar problem when it came to my bibliography in an article submission. I wanted to use the short title, but it kept being populated with the full title. This happened regardless of what I put in the journal and alternate journal titles, and what I put inthe bibliography part of the style.

The resolution was to change the setting in the journal section of the style manager, not the bibliography. There you can select which journal format you want to use ie full name or abbreviation. Despite wanting the abbreviated title I selected full title. This was because when I looked at how references had been imported (tools>openterms>journals)  abbreviated titles were tagged as full title, and full title abbreviated as tagged.

I have to say, Endnote does manage to make things incredibly complicated.