Missing bibliography after importing PDF articles

I am working with last version of EndNote on iMac.
After importing large folder of PDF references, many of those files have no bibliography data being imported. They are recent peer-reviewed articles with DOI numbers, I found no reason for not having their bib. imported. Maybe because I had some connection trouble at the time of importing?
Is there anyway to update those references data on the endnote library?

If I understand your question correctly, you’ve imported PDFs into EndNote but the fields are not populated. You should try the Find Reference Updates feature

You will need to make sure to enter something unique into the empty record (for exampe, the title of the paper, the DOI, the PMID, etc.), then save the record (important step), before trying the Find Reference Updates feature. This video goes over the process:


If EndNote is still not able to update the reference, then you will have to manually enter the reference.

Hi Tony - I have a similar problem.  This process is one of the weakest parts of using EndNote at the moment.  Last month I found that there is also no easy way to reconcile a citation record with a blank record put on a PDF.  Today, I tried dragging and dropping a PDF into a reference and it didn’t work.  So I have a library full of PDFs and full of citations, and I can search in the PDFs for the title, and find it, but then I would apparently have to save the PDF out to disk and then import it?

This is terrible. Clicking through several screens to find, transcribe and save dx.doi data is bad. Make Endnote automate that.

1 Like

I will pass along this suggestion to our Developers.

TMartin Please do!  this is one of the most important features missing from Endnote, in my humble opinion.  

You should make a point to enter something one of a kind into the void record (for exampe, the title of the paper, the DOI, the PMID, and so forth.), then spare the record (vital stride), before attempting to find reference updates.