Problem when searching with "Match words" option for only one letter.

When I search with “Match words” option, I find that when the word is only one letter, it doesn’t work well. For example, when I search “W” with “Match words” option, then references with “Water” will be found. (When I search “Au”, it works well, and reference with “Augest” doesn’t appear in the find results.)

I use Endnote X3.

If searching for a word that’s a single letter (i.e., “A”), put a blank space after the letter.

1 Like

Thank you very much!

But it doesn’t work for my case.

When I search "W " with “Match words” option, no results are found when there is a reference with "W    ".

That’s odd as selecting “Match Case” then typing a letter followed by a space (without enclosed quotation marks: A ) seems to work for me.  Just running through a checklist:  1) Are you placing the search criteria (e.g., W ) in the correct search field (i.e., Title)?  2) Are you omitting enclosed quotation marks?

1 Like

Thank you very much for you help!

  1. Yes, I put the “W” in the correct field.

  2. Yes, I have tested both "W " and W with a space without quotation marks. None of them works.

I want to use “Match words” to distinguish the references with W, vdW, Water and etc.

I used Endnote X3.

Could you tell me what version are you using?

Thanks for the info.  I’m using X3.

I was able to search by single letter but it seems to work when using Match Case, not Match Words.  Given your search parameters which seem to include both case and word(s), have you checked both the Match Case and Match Words options?  And are you using separate fields to build the search terms?

Message Edited by CrazyGecko on 01-24-2010 08:37 AM

1 Like

Thank you for your help.

I used both “Match Case” and “Match Words” to distinguish references with W, water or vdW.

The problem is for “Match words”, and it seems that it works well for at least two letters.

When all else fails, it’s time to check the manual.  Page 235 lists two caveates for “Match Words” and “Match Case”:

“With ‘Match Words’ selected, EndNote finds only exact matches to the search term, rather than partial-word matches…”

As for “Match Case”, it appears the feature is case-sensitive so the entered search term (or letter) must appear exactly the same as what’s in the records. 

1 Like

According to the manual, when I search “W” with the options “Match Words” and “Match Case”, I should not find the references with such as Water, vdW, but actually I get the results with Water and vdW.

Maybe the single letter is not considered as a word in EndNote.

But for me, W is the the symbol for the element tungsten. (it is obvious that W is convenient to tungsten)

It does seem that way (single letter is not a word) - which might make sense in some instances and clearly doesn’t for yours.  Perhaps this is something to take up with tech support and if anyone on the forum has insight on using Match Words/Match Case and their limitations, post your comments.

1 Like

Thank you for your help!

I know this thread is now considered closed but I’ve just had the same problem with a two letter name. I tried finding Li in my references, for which I have 4 as the primary author, and kept getting the ‘no results’ comment back. I’ve just tried your suggestion and it worked. I thought I would let you know that one letter words are not the only issue. Thanks for the help you probably didn’t even realise you were giving.

This thread is pretty old, but the problem persists.  In my case, I use work with the R software package and the word R shows up a lot in titles and keyword lists.  I would really appreciate it if the developers could take another look at this problem.  For now I have to resort to a long list of search terms using the OR operator, including all the different permutations of R and surrounding punctuation.

Does anybody have any new suggestions?

FWIW I also don’t think this topic should be marked as “solved”.  The OP wanted a way to search for single letter words, and none was provided, so it isn’t really solved.


But the OP marked solved – no one else can!  and I agree there should be a better way to search for a single letter!  

I am sorry I set it as solved.

It seems that there is no way to solve this problem-- only if the developers want.

i have this problem too, and i don’t know how to solve it yet…