Problems importing publication date 2010 from PubMed

I am using Endnote v 9 and regularly import citations from PubMed (save as a file from PubMed, open Endnote, import using a slightly modified PubMed filter).

As citations are starting to have 2010 publication dates, these citations show up without a number in the year field in my library.

The filter has the following form for date of publication:


DP-Year Date

which worked just fine for 2009 citations, but it does not seem able to handle citations with

DP  - 2010 Jan

Any ideas?

johneast pointed out a possibility in this thread that older version of Endnote may not import year after 2010.

It’s unbelievable, when so many Y2K problems were around, developers didn’t think about 10 years later.

Or, was this the plan to force everybody to upgrade around 2010?

  I agree with myoshigi that it is really unconscionable that Thompson Reuters  would produce a product which cannot do the simple task of correctly importing a date of 2010 from Pubmed and then the fix is to force you to purchase an upgrade if you don’t have one of the most recent versions?  I am using Endnote X.02 for the Macintosh and now unless I want to manually add the correct year of publication, I will have to upgrade.  I’ve been using Endnote since the earliest versions nearly 20 years ago when it was simply Endnote with an add on program called Endlink which enhanced the program in some way which I cannot even remember.  I keep a personal library now containing over 7,000 references that I use to manage reprints and write papers and grants.  When there are new features that I want because I perceive them to be useful, or that are required to be compatible with new versions of Microsoft Word etc, then I upgrade, but I really object to being required to upgrade in order to fix a coding error that the programmers made a few years ago.

If it is a problem reproduced by the earlier versions <X1, they should provide a patch for free.

But in the meantime, let’s not jump on the conclusion all the earlier versions <X1 have the 2010 problem. It could be some errors specific to the filter being used by the user. I’ll do some testing with my X and X1 later, when I have some spare time.

Besides, if you have 7000 references, please tell us how you organize your database, spend a few more minutes on how we can improve productivity. Voices from long time users like you can change (and improve) the software. I also miss the days of Endlink, huge collection of INDEX MEDICUS in the library, and pain of changing reference numbers if they are more than 20. We came all the long way.

Hi All, 

I tested several earlier EN versions for Windows to see if they can import 2010 appropriately from Pubmed using MEDLINE export and import by dafault filters (not by custom made filters or connection files). My tests indicate that all the earlier versions exept for X3 are not able to import year beyond 2010.

I changed date import tags of the following filter files: MEDLINE (Ovid), MEDLINE (SP), MEDLINE (OvidSP), Pubmed (NLM). All of them were the original filters came with each version, not the one modifed by myself. These filters use either YR, SO, or DP tags, and use smart parsing if either of them cannot import year data. So, I edited a text file, exported from recent Pubmed citations, and changed only the year in these lines, like changing from 2009 to 2010 in both DP and SO lines, or 2010 for DP line leaving SO line as 2009, etc. Then, imported to temporary endnote library. When DP or YR lines are changed to 2010, and SO line has 2009, year was imported as 2009. If both lines of DP (YR) and SO lines were changed to 2010, year was not imported and became blank. All versions from 9 to X2 showed the same problem. Only X3 imported 2010 correctly.

I tested only Windows versions immediately available, even I have most of old-older versions like 2.0 through 8 for both Mac and Win. But I don’t think it was necessary to test them. By the way, Help files mention that only four digit data 1### or 200# are imported, as johneast pointed out. Interestingly, the help file of X3 still mentions in the same way, but X3 imported 2010 appropriately.

Anyway, that’s it. Let me know if anyone else can reproduce my results or get results differently in different environment. This was not an exaustive test, but rather a short test. However, the test indicated a serious problem, Thomson Reuters may need to consider a patch, if this is true.

My testing environment was as follows.

Windows XP Pro, SP3. No MS Office installed. 3.1 installed.

Endnote version tested: 9, X, X1, X2, and X3

Best regards,

[Edit] I forgot to mention. I did these tests by uninstalling program files, erasing all the preferences, and reinstalling the next version one after another. So, it should not be affected by some preference setups of other versions.

Message Edited by myoshigi on 12-19-2009 06:21 AM

I tested X2/Win with another PC, just to make sure my result of 2010 import problem is reproducible. And indeed it was reproducible.

I have attached two sample text files, originating text data downloaded from

The original text is just a random one from Stem Cells, and both DP and SO lines had 2009. I changed these lines to 2010, to test this error.

Anybody who are using Endnote versions 9 - X2, you could test importing using MEDLINE filter you’ve been using or Pubmed (NLM) filter. If you import the file with 2009 normally, but blank year field with 2010 one, then it is really 2010 problem.

I’m going to write this to Thomson Reuters tech support page.
Pubmed Text Sample 2009.txt (2.85 KB)
Pubmed Text Sample 2010.txt (2.85 KB)

I’m learning more towards this, and really really surprised at what I’ve found.

Look at this FAQ about 2010 problem:

It’s not an “issue”, it is a bug, or more correctly “defect” in the previous version.

They knew this DEFECT, but they don’t officially support versions 8-X. So their logic is, users with these versions won’t receive patch, and forced to upgrade to X3. This is a terrible decision, Thomson Reuters! If online download/import doesn’t work, I’m pretty much sure Endnote will be useless and lameduck.

I have checked my purchase record and it shows that I bought version X in the second half of 2006. I’m pretty much sure, I’m among the first group of people who buy the upgrade. This means, software is supported only 4 years??? If it is a functional limitation, such as issues with group function added later, I understand. But this is the “import” function that’s been core of the Endnote since the birth, and you call it “known issue” for the version less than 5 years old?? Even car manufactures provide free repair long after warranty expiration, if it is a functional DEFECT.

Your decision would lead to a serious back-lash from users, and in fact, I can turn my colleagues (which could be easily more than 100 people) to sotware other than Endnote saying, because support (philosophy) sucks! I seriously and strongly suggest Thomson Reuters staffs to change the decision and consider providing 2010 patch for users with 8-X. Not all the people can afford $100 upgrade cost every other year. This could easiy turn thousands of version 8-X users to Zoteoro, and I would actually recommend doing so if it doesn’t import 2010 data.

Don’t you agree everyone!?

Message Edited by myoshigi on 12-19-2009 02:59 PM

1 Like

I concur.  Thomson, you need to fix this for your entire user base.  

Message Edited by Leanne on 12-20-2009 01:37 PM

Same problem with Web of Science, by the way.

did you try the new patch?

Yes, I installed the patch in the meantime, and now the year 2010 gets imported into EndNote X2 again.

I have just tried it with my EndNote 8.0.2 and definitely, it haven’t worked. Now, no year is included (not only 2010).  We have done it twice, double checking all the process by two people…  I’m really upset!

Does anyone experienced this same problem with v.8?

I think you need to download a plug- in for older versions of Endnote:  See this FAQ on the endnote website.

My solution was to upgrade to a newer version :frowning:

Actually, Endnote8 was not my favorite release for a multitude of reasons, so  I don’t think that is a bad choice.  There are a lot of new features I think you will enjoy.  so really :wink:

Make sure you understand the different modes, as an established user, I think you will prefer not using the “default” integrated mode, but prefer jumping between library and online modes. 

You should also uninstall EN8 before installing any EN X* version and make sure that there are no residual toolbars in Word before installing EN X* versions. 

Then do watch some of the training videos (see the training forum for links) so you get a feel for the newer interface and features. 

I had the same problem as roseruf with the patch, using version X. However Myoshigi’s tests gave me a handy workaround. PubMed exports now include the citation in the SO field. To extract the year (for any year) from this, go to the edit import filter and at SO, enter {IGNORE} Year {IGNORE}. Hope this helps in other versions, too!

For quite a while a thought this to be a problem of PubMed.

I am glad to have found this blog. I downloaded the patches today and with Endnote X (2006 version for Mac) it works fine.

It is nice to see that consumer pressure sometimes works.

It’s unbelievable, when so many Y2K problems were around, developers didn’t think about 10 years later.


hàng xách tay, HANG XACH TAY

All versions of EndNote going back to version X1 (released in 2007) can now import records from 2010 and later. EndNote X1 and X2 would need to be fully updated. EndNote X3 and later do not require any updates for this to work. EndNote versions 8, 9 and X can do so using the plug-in mentioned in this article:

These versions of EndNote can now import records whether they are from 2013 or 3013 and later. I hope this helps.

Jason Berman
Technical Sup Rep RS

Thomson Reuters

Phone: +1 800-336-4474