Same reference in consecutive citations

Is it just me or does EndNote handle this function (essentially, the ibid function) poorly?

If I edit a reference in Word, with an output style configured to use the “Cited Pages” field, why does EndNote treat another citation with no Cited Pages, or even *different* Cited Pages as the “Same Reference”?  Seems to me this is the fundamental difference between “Same Reference” and “Same Source”, both of which are provided for in the “Repeated Citations” section of the output style.  Am I missing something?  Why do citations with different “Cited Pages” just revert to ibid?  I would like EndNote to handle this case differently from the short form, otherwise what is the point of having a “Cited Pages” function at all if EndNote treats them as the same reference?  You can achieve the same result by adding suffixes yourself, outside of the field, in Word, assuming (as usual) they are the last element of the citation.

Also, it’s kind of stupid that you need to use a zero-width space to stop EndNote using a lower-caps “ibid” if you are using flush left footers in Word.  The need to overcome the poor design of Word and EndNote at the same time is really pushing me to the limits of my sanity and ingenuity.

Perhaps I should add to my list of gripes that a clean install of X6 hasn’t fixed the bug with CWYW that causes the “Edit Citation(s)” dropdown tool to have a second leve (indicated by the >) that has nothing in it, meaning the only way to edit a citation quickly is with the shortcut.

I should also add that neither a different Suffix, nor different Cited Pages, causes EndNote to treat the previous citation as a different reference.  Which kind of begs the question - what is the difference?

I’ve noticed that EndNote does in fact omit the Cited Pages number if it is identical to the previous reference.  Does this mean that the Repeated “Same Source” option is totally redundant?

(I really wish this forum was advanced enough to let you edit a post…)

EndNote doesn’t seem to let me include a page range in Cited Pages (eg, Cited Pages=“2-3” formats as “2” only) – what’s up with that?

Fixed the page number issue - noticed the totally separate tab.

@blindside wrote:

(I really wish this forum was advanced enough to let you edit a post…)

Click the “Options” pull-down menu located in the upper-right corner of the posted message and select “Edit Reply”,.

There is no “Edit Reply” option, either for my original thread or for subsequent posts…

That is very strange.  I can edit any post I posted, but can only delete ones that haven’t been replied to.  Hence if I deleted this, you could delete yours, and so on down the thread… You can only edit your own posts obviously - if you are logged in though.