Sort order with different types of sources

Hello all,

I have a problem with sorting my bibliography and maybe someone could give me a few hints on how to do this.

I’m using two different categories of titles: my sources are mostly newspaper articles which are quoted “Newspaper from Date: Title”, my literature is mostly monographs and magazine articles. Now with the literature, the sort order “Author” + “Year” + “Title” seems to work, however with the sources, it doesn’t and they just seem to be ‘sorted’ at random.

For example this is the current output with the above rules for sorting:


Bauman, Zygmunt: Modernity and the Holocaust. Ithaca, NY 1989.

Cathart, Michael: The Water Dreamers. The remarkable History of our dry Continent. Melbourne 2009.

Cooper, Frederick: Colonialism in Question. Theory, Knowledge, History. Berkeley, Los Angeles, London 2005. (etc.)


The Sydney Mail vom 02.05.1928. “Hume Reservoir: World’s Second Largest”.

The Argus vom 27.03.1925. “Hume Reservoir. Key of Murray Works”.

The Sydney Mail vom 15.05.1935. “The Murray River Irrigation Scheme”.

The Argus vom 15.07.1922. “Murray Water Conservation. The Hume Weir”.

The Argus vom 29.11.1919. “Murray Water Storage. Colossal Undertaking. Fifth largest in the World”. (etc.)

My logic is, that if there is there is no value given for “Author”, then Endnote would skip it and sort the titles according to “Year” and then “Title”, but this doesn’t seem to be the case. Instead, it just seems to stop sorting at all.

It would be great if anyone had an idea on how to solve this. Thanks alot.


There seems to be a couple of things going on in your case

  1. Yes, it would seem sort order of Author + Year + Title would default to the order of Year + Title when there are no authors. However, this is where the “Anonymous Works” setting of the Endnote output style comes into play. The Anonymous Works setting is usually set to handle anonymous authors according to the style’s specifications (e.g., APA, MLA, etc.)  which then uses the Title field.

The Anonymous Works setting has other options and the only one which permit an inclusive and correct chronological sorting of author-less treferences is to have the word “Anonymous” treated as the Author  (see attached image*) - which means “Anonymous” will be listed as the author for each author-less reference. 

  1. The way you entered  dates  by placing  the year in the last position  due to the  means  Endnote  is going to first  sort by the day, not year.  To prevent this you need to place  the year first:


*Note: To change the setting go to the EndNote toolbar, select Edit > Output Styles > Edit [name of the output style.] Locate the Bibliography section then click the Anonymous works setting (see attached image). Note that modifying the output style will cause the changes to be saved as a new output style file with the word Copy appended to the file name so change MS Word/EndNote to use the new file.
output style setting_anonymous works.gif

Hi, thanks for the quick reply!

Unfortunately this solution doesn’t work for me, though. I tried setting Endnote to substitute an empty “Author”-field for “Anonymous”, but it didn’t have any effect. I suspect it’s because the sources are defined as “Newspaper Article” and thus, there is no “Author”-field to begin with.

The other problem is that my paper is in German, so I cannot format the date according to, because in German you write

I however tried a different approach which almost works. I set the sort order manually as follows: 1) Author; 2) Year; 3) Date; 4) Title. Since I have entered year and date for the sources, it now places them in the correct order, except for one problem:

The Argus vom 09.12.1936. “Sir Edward Harding. Visits Hume Weir”.

The Age vom 20.11.1936. “Hume Dam will enrich three States”.

The Argus vom 20.11.1936. “Hume Reservoir to be opened to-morrow. 15-Year Task which cost £5,500,00”.

The Argus vom 23.11.1936. “Great Hume Reservoir opened. Thousands at important Ceremony”.

The Sydney Mail vom 25.11.1936. “Australia’s Great Dam. Opened by the Governor-General”.

The Sydney Mail vom 25.11.1936. “THE HUME DAM - Official Opening of the Great National Work”.

With those sources which are all the same year it doesn’t sort correctly. The first item is dated december 9th 1936 (“09.12.”), the second is dated november 20th 1936 (“20.11.”) and thus december should get sorted after november, not before. I suspect this is again due to Endnote assuming that I input dates according to and thus puts “09” before “20”. Again, I cannot change this, but maybe there is a way to get Endnote to recognize that I’m using a different way to format dates? Setting the sort language to “German” unfortunately didn’t do the trick…

Thanks again for your time!

Yes, thanks for noting that there is an option in Anonymous Works to “Leave author blank” - thanks, developers! That just leaves addressing the date-sorting issue.

  1. A workaround is to use Endnote’s Change/Move/Copy Fields feature to copy the contents from the Year field into the Date field (or you can set up a custom field across the reference types). (Go to the Endnote toolbar and select Tools > Change/Move/Copy Fields. Then in the pop-up dialog box, Move/Copy Fields tab. Select “Copy Field”, choose “Year” and “Date” as the From/To fields, and select “Replace Entire Field”. Then click OK.)
  2. Next, manually change the mm.dd.yyyy date order in the Date field (for applicable reference records) to:
  3. Finally, change the bibliography sort order of your output style to: Author + Date + Title. This will enable sorting the bibliography references in ascending chronological order based on the Date field (not Year). But since the bibliography template uses the Year field the applicable references will be shown in the bibliography with the mm.dd.yyyy date.

Good idea to work around the issue like that. Bit of a hassle, but keeps me from having to sort manually at the end.